lantiq: cleanup the dsl control scripts
authorJohn Crispin <john@openwrt.org>
Sat, 5 Apr 2014 16:34:20 +0000 (16:34 +0000)
committerJohn Crispin <john@openwrt.org>
Sat, 5 Apr 2014 16:34:20 +0000 (16:34 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 40381

package/network/config/ltq-adsl-app/Config.in [deleted file]
package/network/config/ltq-adsl-app/Makefile
package/network/config/ltq-adsl-app/files/dsl_control
package/network/config/ltq-adsl-app/files/dsl_notify.sh [deleted file]
package/network/config/ltq-vdsl-app/Makefile
package/network/config/ltq-vdsl-app/files/dsl_control
package/network/config/ltq-vdsl-app/files/dsl_notify.sh [deleted file]
target/linux/lantiq/base-files/lib/functions/lantiq_dsl.sh [new file with mode: 0644]
target/linux/lantiq/base-files/sbin/dsl_notify.sh [new file with mode: 0644]

diff --git a/package/network/config/ltq-adsl-app/Config.in b/package/network/config/ltq-adsl-app/Config.in
deleted file mode 100644 (file)
index 728fe65..0000000
+++ /dev/null
@@ -1,9 +0,0 @@
-config LTQ_DSL_ENABLE_SOAP
-       bool "Enable SOAP support"
-       depends on PACKAGE_ltq-dsl-app
-       default n
-
-config LTQ_DSL_ENABLE_DSL_EVENT_POLLING
-       bool "Include Event Polling support"
-       depends on PACKAGE_ltq-dsl-app
-       default n
index 92445e55800049b765fddd0592ee66f6a912b482..639ed1e6b1a4e32a4b95e659d456596fb7405a78 100644 (file)
@@ -40,10 +40,6 @@ define Package/ltq-adsl-app/description
        Infineon DSL CPE API for Amazon SE, Danube and Vinax.
 endef
 
-define Package/ltq-adsl-app/config
-       source "$(SOURCE)/Config.in"
-endef
-
 LTQ_DSL_MAX_DEVICE=1
 LTQ_DSL_LINES_PER_DEVICE=1
 LTQ_DSL_CHANNELS_PER_LINE=1
@@ -74,16 +70,6 @@ CONFIGURE_ARGS += \
        --enable-dsl-pm-line-thresholds \
        --enable-dsl-pm-optional-parameters
 
-ifeq ($(CONFIG_LTQ_DSL_ENABLE_SOAP),y)
-CONFIGURE_ARGS += \
-       --enable-soap-support
-endif
-
-ifeq ($(CONFIG_LTQ_DSL_ENABLE_DSL_EVENT_POLLING),y)
-CONFIGURE_ARGS += \
-       --enable-dsl-event-polling
-endif
-
 TARGET_CFLAGS += -I$(LINUX_DIR)/include
 
 define Package/ltq-adsl-app/install
@@ -92,7 +78,6 @@ define Package/ltq-adsl-app/install
 
        $(INSTALL_DIR) $(1)/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/dsl_cpe_control $(1)/sbin
-       $(INSTALL_BIN) ./files/dsl_notify.sh $(1)/sbin
 endef
 
 $(eval $(call BuildPackage,ltq-adsl-app))
index e8a286f2bb62f42a4754347ae299e8cb050ec341..d48f3f62667b54e48a64f7c74a2300376e7fc9ed 100644 (file)
@@ -10,252 +10,7 @@ EXTRA_HELP="        status  Get DSL status information
 SERVICE_DAEMONIZE=1
 SERVICE_WRITE_PID=1
 
-#
-# Basic functions to send CLI commands to the dsl_cpe_control daemon
-#
-dsl_cmd() {
-       killall -0 dsl_cpe_control && (
-               echo "$@" > /tmp/pipe/dsl_cpe0_cmd
-               cat /tmp/pipe/dsl_cpe0_ack
-       )
-}
-dsl_val() {
-       echo $(expr "$1" : '.*'$2'=\([-\.[:alnum:]]*\).*')
-}
-
-#
-# Simple divide by 10 routine to cope with one decimal place
-#
-dbt() {
-       local a=$(expr $1 / 10)
-       local b=$(expr $1 % 10)
-       echo "${a}.${b}"
-}
-#
-# Take a number and convert to k or meg
-#
-scale() {
-       local val=$1
-       local a
-       local b
-
-       if [ "$val" -gt 1000000 ]; then
-               a=$(expr $val / 1000)
-               b=$(expr $a % 1000)
-               a=$(expr $a / 1000)
-               printf "%d.%03d Mb" ${a} ${b}
-       elif [ "$val" -gt 1000 ]; then
-               a=$(expr $val / 1000)
-               printf "%d Kb" ${a}
-       else
-               echo "${val} b"
-       fi
-}
-
-#
-# Read the data rates for both directions
-#
-data_rates() {
-       local csg
-       local dru
-       local drd
-       local sdru
-       local sdrd
-
-       csg=$(dsl_cmd g997csg 0 1)
-       drd=$(dsl_val "$csg" ActualDataRate)
-
-       csg=$(dsl_cmd g997csg 0 0)
-       dru=$(dsl_val "$csg" ActualDataRate)
-
-       [ -z "$drd" ] && drd=0
-       [ -z "$dru" ] && dru=0
-
-       sdrd=$(scale $drd)
-       sdru=$(scale $dru)
-
-       if [ "$action" = "lucistat" ]; then
-               echo "dsl.data_rate_down=$drd"
-               echo "dsl.data_rate_up=$dru"
-               echo "dsl.data_rate_down_s=\"$sdrd\""
-               echo "dsl.data_rate_up_s=\"$sdru\""
-       else
-               echo "Data Rate:                ${sdrd}/s / ${sdru}/s"
-       fi
-}
-
-#
-# Chipset
-#
-chipset() {
-       local vig
-       local cs
-       local csv
-
-       vig=$(dsl_cmd vig)
-       cs=$(dsl_val "$vig" DSL_ChipSetType)
-       csv=$(dsl_val "$vig" DSL_ChipSetHWVersion)
-
-       if [ "$action" = "lucistat" ]; then
-               echo "dsl.chipset=\"${cs} ${csv}\""
-       else
-               echo "Chipset:          ${cs} ${csv}"
-       fi
-}
-
-#
-# Work out how long the line has been up
-#
-line_uptime() {
-       local ccsg
-       local et
-       local etr
-       local d
-       local h
-       local m
-       local s
-       local rc=""
-
-       ccsg=$(dsl_cmd pmccsg 0 0 0)
-       et=$(dsl_val "$ccsg" nElapsedTime)
-
-       [ -z "$et" ] && et=0
-
-       if [ "$action" = "lucistat" ]; then
-               echo "dsl.line_uptime=${et}"
-               return
-       fi
-
-       d=$(expr $et / 86400)
-       etr=$(expr $et % 86400)
-       h=$(expr $etr / 3600)
-       etr=$(expr $etr % 3600)
-       m=$(expr $etr / 60)
-       s=$(expr $etr % 60)
-
-
-       [ "${d}${h}${m}${s}" -ne 0 ] && rc="${s}s"
-       [ "${d}${h}${m}" -ne 0 ] && rc="${m}m ${rc}"
-       [ "${d}${h}" -ne 0 ] && rc="${h}h ${rc}"
-       [ "${d}" -ne 0 ] && rc="${d}d ${rc}"
-
-       [ -z "$rc" ] && rc="down"
-       echo "Line Uptime:              ${rc}"
-}
-
-#
-# Get noise and attenuation figures
-#
-line_data() {
-       local lsg
-       local latnu
-       local latnd
-       local snru
-       local snrd
-
-       lsg=$(dsl_cmd g997lsg 1 1)
-       latnd=$(dsl_val "$lsg" LATN)
-       snrd=$(dsl_val "$lsg" SNR)
-
-       lsg=$(dsl_cmd g997lsg 0 1)
-       latnu=$(dsl_val "$lsg" LATN)
-       snru=$(dsl_val "$lsg" SNR)
-
-       [ -z "$latnd" ] && latnd=0
-       [ -z "$latnu" ] && latnu=0
-       [ -z "$snrd" ] && snrd=0
-       [ -z "$snru" ] && snru=0
-
-       latnd=$(dbt $latnd)
-       latnu=$(dbt $latnu)
-       snrd=$(dbt $snrd)
-       snru=$(dbt $snru)
-       
-       if [ "$action" = "lucistat" ]; then
-               echo "dsl.line_attenuation_down=$latnd"
-               echo "dsl.line_attenuation_up=$latnu"
-               echo "dsl.noise_margin_down=$snrd"
-               echo "dsl.noise_margin_up=$snru"
-       else
-               echo "Line Attenuation: ${latnd}dB / ${latnu}dB"
-               echo "Noise Margin:             ${snrd}dB / ${snru}dB"
-       fi
-}
-
-#
-# Is the line up? Or what state is it in?
-#
-line_state() {
-       local lsg=$(dsl_cmd lsg)
-       local ls=$(dsl_val "$lsg" nLineState);
-       local s;
-
-       case "$ls" in
-               "0x0")          s="not initialized" ;;
-               "0x1")          s="exception" ;;
-               "0x10")         s="not updated" ;;
-               "0xff")         s="idle request" ;;
-               "0x100")        s="idle" ;;
-               "0x1ff")        s="silent request" ;;
-               "0x200")        s="silent" ;;
-               "0x300")        s="handshake" ;;
-               "0x380")        s="full_init" ;;
-               "0x400")        s="discovery" ;;
-               "0x500")        s="training" ;;
-               "0x600")        s="analysis" ;;
-               "0x700")        s="exchange" ;;
-               "0x800")        s="showtime_no_sync" ;;
-               "0x801")        s="showtime_tc_sync" ;;
-               "0x900")        s="fastretrain" ;;
-               "0xa00")        s="lowpower_l2" ;;
-               "0xb00")        s="loopdiagnostic active" ;;
-               "0xb10")        s="loopdiagnostic data exchange" ;;
-               "0xb20")        s="loopdiagnostic data request" ;;
-               "0xc00")        s="loopdiagnostic complete" ;;
-               "0x1000000")    s="test" ;;
-               "0xd00")        s="resync" ;;
-               "0x3c0")        s="short init entry" ;;
-               "")             s="not running daemon"; ls="0xfff" ;;
-               *)              s="unknown" ;;
-       esac
-
-       if [ $action = "lucistat" ]; then
-               echo "dsl.line_state_num=$ls"
-               echo "dsl.line_state_detail=\"$s\""
-               if [ "$ls" = "0x801" ]; then
-                       echo "dsl.line_state=\"UP\""
-               else
-                       echo "dsl.line_state=\"DOWN\""
-               fi
-       else
-               if [ "$ls" = "0x801" ]; then
-                       echo "Line State:               UP [$ls: $s]"
-               else
-                       echo "Line State:               DOWN [$ls: $s]"
-               fi
-       fi
-}
-
-#
-# Main status routine
-#
-status() {
-       chipset
-       line_state
-       data_rates
-       line_data
-       line_uptime
-}
-
-#
-# Luci (lua) compatible version that's easy to parse
-#
-lucistat() {
-       echo "local dsl={}"
-       status
-       echo "return dsl"
-}
-
+. /lib/functions/lantiq_dsl.sh
 
 annex_b=10_00_10_00_00_04_00_00
 annex_bdmt=10_00_00_00_00_00_00_00
@@ -272,9 +27,6 @@ annex_m=00_00_00_00_40_00_04_00
 annex_m2=00_00_00_00_40_00_00_00
 annex_m2p=00_00_00_00_00_00_04_00
 
-#
-# Simple start routine
-#
 start() {
        local annex
        local firmware
@@ -283,24 +35,16 @@ start() {
        config_get annex wan annex
        config_get firmware wan firmware
 
-       # get xtu
        eval "xtu=\"\${annex_$annex}\""
 
-       # check for firmware
        [ -z "${firmware}" ] &&
                firmware=adsl.bin
 
-       # start CPE dsl daemon in the background
        service_start /sbin/dsl_cpe_control -i${xtu} \
                        -n /sbin/dsl_notify.sh \
                        -f /lib/firmware/${firmware}
 }
 
-#
-# For stop we want to simulate the notification call for when
-# the line goes down, so that we can stop the ppp link before
-# we die.
-#
 stop() {
        DSL_NOTIFICATION_TYPE="DSL_INTERFACE_STATUS" \
        DSL_INTERFACE_STATUS="DOWN" \
diff --git a/package/network/config/ltq-adsl-app/files/dsl_notify.sh b/package/network/config/ltq-adsl-app/files/dsl_notify.sh
deleted file mode 100644 (file)
index 5e9f396..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-#!/bin/sh
-#
-# This script is called by dsl_cpe_control whenever there is a DSL event,
-# we only actually care about the DSL_INTERFACE_STATUS events as these
-# tell us the line has either come up or gone down.
-#
-# The rest of the code is basically the same at the atm hotplug code
-#
-
-[ "$DSL_NOTIFICATION_TYPE" = "DSL_INTERFACE_STATUS" ] || exit 0
-
-. /lib/functions.sh
-
-include /lib/network
-scan_interfaces
-
-local found=0
-local ifc
-for ifc in $interfaces; do
-       local up
-       config_get_bool up "$ifc" up 0
-
-       local auto
-       config_get_bool auto "$ifc" auto 1
-
-       local proto
-       config_get proto "$ifc" proto
-
-       if [ "$DSL_INTERFACE_STATUS" = "UP" ]; then
-               if [ "$proto" = "pppoa" ] && [ "$up" != 1 ] && [ "$auto" = 1 ]; then
-                       found=1
-                       ( sleep 1; ifup "$ifc" ) &
-               fi
-       else
-               if [ "$proto" = "pppoa" ] && [ "$up" = 1 ] && [ "$auto" = 1 ]; then
-                       found=1
-                       ( sleep 1; ifdown "$ifc" ) &
-               fi
-       fi
-done
-
-if [ "$found" != 1 ]; then
-       logger "Found no matching interface for DSL notification ($DSL_INTERFACE_STATUS)"
-fi
index d4e4ec4501db74b3cf9f4cbd954e84c69fb31c86..ee95860f383f4e24f08a13c295a6863d3720d975 100644 (file)
@@ -71,7 +71,6 @@ define Package/ltq-vdsl-app/install
 
        $(INSTALL_DIR) $(1)/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/dsl_cpe_control $(1)/sbin/vdsl_cpe_control
-       $(INSTALL_BIN) ./files/dsl_notify.sh $(1)/sbin
 endef
 
 $(eval $(call BuildPackage,ltq-vdsl-app))
index 0d7d32cb0b2f9d72338ef3f5cb3960fcdd776c3e..8f248238517476dc1ff5bffc886c2888f8022fff 100644 (file)
@@ -10,297 +10,29 @@ EXTRA_HELP="       status  Get DSL status information
 SERVICE_DAEMONIZE=1
 SERVICE_WRITE_PID=1
 
-#
-# Basic functions to send CLI commands to the vdsl_cpe_control daemon
-#
-dsl_cmd() {
-       killall -0 vdsl_cpe_control && (
-               echo "$@" > /tmp/pipe/dsl_cpe0_cmd
-               cat /tmp/pipe/dsl_cpe0_ack
-       )
-}
-dsl_val() {
-       echo $(expr "$1" : '.*'$2'=\([-\.[:alnum:]]*\).*')
-}
-
-#
-# Simple divide by 10 routine to cope with one decimal place
-#
-dbt() {
-       local a=$(expr $1 / 10)
-       local b=$(expr $1 % 10)
-       echo "${a}.${b}"
-}
-#
-# Take a number and convert to k or meg
-#
-scale() {
-       local val=$1
-       local a
-       local b
-
-       if [ "$val" -gt 1000000 ]; then
-               a=$(expr $val / 1000)
-               b=$(expr $a % 1000)
-               a=$(expr $a / 1000)
-               printf "%d.%03d Mb" ${a} ${b}
-       elif [ "$val" -gt 1000 ]; then
-               a=$(expr $val / 1000)
-               printf "%d Kb" ${a}
-       else
-               echo "${val} b"
-       fi
-}
-
-#
-# Read the data rates for both directions
-#
-data_rates() {
-       local csg
-       local dru
-       local drd
-       local sdru
-       local sdrd
-
-       csg=$(dsl_cmd g997csg 0 1)
-       drd=$(dsl_val "$csg" ActualDataRate)
-
-       csg=$(dsl_cmd g997csg 0 0)
-       dru=$(dsl_val "$csg" ActualDataRate)
-
-       [ -z "$drd" ] && drd=0
-       [ -z "$dru" ] && dru=0
-
-       sdrd=$(scale $drd)
-       sdru=$(scale $dru)
-
-       if [ "$action" = "lucistat" ]; then
-               echo "dsl.data_rate_down=$drd"
-               echo "dsl.data_rate_up=$dru"
-               echo "dsl.data_rate_down_s=\"$sdrd\""
-               echo "dsl.data_rate_up_s=\"$sdru\""
-       else
-               echo "Data Rate:                ${sdrd}/s / ${sdru}/s"
-       fi
-}
+. /lib/functions/lantiq_dsl.sh
+XDSL_CTRL=vdsl_cpe_control
 
-#
-# Chipset
-#
-chipset() {
-       local vig
-       local cs
-       local csv
-
-       vig=$(dsl_cmd vig)
-       cs=$(dsl_val "$vig" DSL_ChipSetType)
-       csv=$(dsl_val "$vig" DSL_ChipSetHWVersion)
-
-       if [ "$action" = "lucistat" ]; then
-               echo "dsl.chipset=\"${cs} ${csv}\""
-       else
-               echo "Chipset:          ${cs} ${csv}"
-       fi
-}
-
-#
-# Work out how long the line has been up
-#
-line_uptime() {
-       local ccsg
-       local et
-       local etr
-       local d
-       local h
-       local m
-       local s
-       local rc=""
-
-       ccsg=$(dsl_cmd pmccsg 0 0 0)
-       et=$(dsl_val "$ccsg" nElapsedTime)
-
-       [ -z "$et" ] && et=0
-
-       if [ "$action" = "lucistat" ]; then
-               echo "dsl.line_uptime=${et}"
-               return
-       fi
-
-       d=$(expr $et / 86400)
-       etr=$(expr $et % 86400)
-       h=$(expr $etr / 3600)
-       etr=$(expr $etr % 3600)
-       m=$(expr $etr / 60)
-       s=$(expr $etr % 60)
-
-
-       [ "${d}${h}${m}${s}" -ne 0 ] && rc="${s}s"
-       [ "${d}${h}${m}" -ne 0 ] && rc="${m}m ${rc}"
-       [ "${d}${h}" -ne 0 ] && rc="${h}h ${rc}"
-       [ "${d}" -ne 0 ] && rc="${d}d ${rc}"
-
-       [ -z "$rc" ] && rc="down"
-       echo "Line Uptime:              ${rc}"
-}
-
-#
-# Get noise and attenuation figures
-#
-line_data() {
-       local lsg
-       local latnu
-       local latnd
-       local snru
-       local snrd
-
-       lsg=$(dsl_cmd g997lsg 1 1)
-       latnd=$(dsl_val "$lsg" LATN)
-       snrd=$(dsl_val "$lsg" SNR)
-
-       lsg=$(dsl_cmd g997lsg 0 1)
-       latnu=$(dsl_val "$lsg" LATN)
-       snru=$(dsl_val "$lsg" SNR)
-
-       [ -z "$latnd" ] && latnd=0
-       [ -z "$latnu" ] && latnu=0
-       [ -z "$snrd" ] && snrd=0
-       [ -z "$snru" ] && snru=0
-
-       latnd=$(dbt $latnd)
-       latnu=$(dbt $latnu)
-       snrd=$(dbt $snrd)
-       snru=$(dbt $snru)
-       
-       if [ "$action" = "lucistat" ]; then
-               echo "dsl.line_attenuation_down=$latnd"
-               echo "dsl.line_attenuation_up=$latnu"
-               echo "dsl.noise_margin_down=$snrd"
-               echo "dsl.noise_margin_up=$snru"
-       else
-               echo "Line Attenuation: ${latnd}dB / ${latnu}dB"
-               echo "Noise Margin:             ${snrd}dB / ${snru}dB"
-       fi
-}
-
-#
-# Is the line up? Or what state is it in?
-#
-line_state() {
-       local lsg=$(dsl_cmd lsg)
-       local ls=$(dsl_val "$lsg" nLineState);
-       local s;
-
-       case "$ls" in
-               "0x0")          s="not initialized" ;;
-               "0x1")          s="exception" ;;
-               "0x10")         s="not updated" ;;
-               "0xff")         s="idle request" ;;
-               "0x100")        s="idle" ;;
-               "0x1ff")        s="silent request" ;;
-               "0x200")        s="silent" ;;
-               "0x300")        s="handshake" ;;
-               "0x380")        s="full_init" ;;
-               "0x400")        s="discovery" ;;
-               "0x500")        s="training" ;;
-               "0x600")        s="analysis" ;;
-               "0x700")        s="exchange" ;;
-               "0x800")        s="showtime_no_sync" ;;
-               "0x801")        s="showtime_tc_sync" ;;
-               "0x900")        s="fastretrain" ;;
-               "0xa00")        s="lowpower_l2" ;;
-               "0xb00")        s="loopdiagnostic active" ;;
-               "0xb10")        s="loopdiagnostic data exchange" ;;
-               "0xb20")        s="loopdiagnostic data request" ;;
-               "0xc00")        s="loopdiagnostic complete" ;;
-               "0x1000000")    s="test" ;;
-               "0xd00")        s="resync" ;;
-               "0x3c0")        s="short init entry" ;;
-               "")             s="not running daemon"; ls="0xfff" ;;
-               *)              s="unknown" ;;
-       esac
-
-       if [ $action = "lucistat" ]; then
-               echo "dsl.line_state_num=$ls"
-               echo "dsl.line_state_detail=\"$s\""
-               if [ "$ls" = "0x801" ]; then
-                       echo "dsl.line_state=\"UP\""
-               else
-                       echo "dsl.line_state=\"DOWN\""
-               fi
-       else
-               if [ "$ls" = "0x801" ]; then
-                       echo "Line State:               UP [$ls: $s]"
-               else
-                       echo "Line State:               DOWN [$ls: $s]"
-               fi
-       fi
-}
-
-#
-# Main status routine
-#
-status() {
-       chipset
-       line_state
-       data_rates
-       line_data
-       line_uptime
-}
-
-#
-# Luci (lua) compatible version that's easy to parse
-#
-lucistat() {
-       echo "local dsl={}"
-       status
-       echo "return dsl"
-}
-
-
-annex_b=10_00_10_00_00_04_00_00
-annex_bdmt=10_00_00_00_00_00_00_00
-annex_b2=00_00_10_00_00_00_00_00
-annex_b2p=00_00_00_00_00_04_00_00
-annex_a=04_01_04_00_00_01_00_00
-annex_at1=01_00_00_00_00_00_00_00
-annex_alite=00_01_00_00_00_00_00_00
-annex_admt=04_00_00_00_00_00_00_00
-annex_a2=00_00_04_00_00_00_00_00
-annex_a2p=00_00_00_00_00_01_00_00
-annex_l=00_00_00_00_04_00_00_00
-annex_m=00_00_00_00_40_00_04_00
-annex_m2=00_00_00_00_40_00_00_00
-annex_m2p=00_00_00_00_00_00_04_00
-
-#
-# Simple start routine
-#
 start() {
-       local annex
-       local firmware
-       local xtu
+       local firmware xtu
+       
        config_load network
-       config_get annex wan annex
+       
        config_get firmware wan firmware
-
-       # get xtu
-       eval "xtu=\"\${annex_$annex}\""
-
-       # check for firmware
        [ -z "${firmware}" ] &&
                firmware=vdsl.bin
 
-       # start CPE dsl daemon in the background
-       service_start /sbin/vdsl_cpe_control -i${xtu} \
-                       -n /sbin/dsl_notify.sh \
-                       -f /lib/firmware/${firmware}
+       config_get xtu wan xtu
+       [ -z "${xtu}" ] &&
+               xtu=10_00_10_00_00_04_01_07
+
+       service_start /sbin/vdsl_cpe_control \
+               -i${xtu} \
+               -T4_0_1
+               -n /sbin/dsl_notify.sh \
+               -f /lib/firmware/${firmware}
 }
 
-#
-# For stop we want to simulate the notification call for when
-# the line goes down, so that we can stop the ppp link before
-# we die.
-#
 stop() {
        DSL_NOTIFICATION_TYPE="DSL_INTERFACE_STATUS" \
        DSL_INTERFACE_STATUS="DOWN" \
@@ -308,4 +40,3 @@ stop() {
 
        service_stop /sbin/vdsl_cpe_control
 }
-
diff --git a/package/network/config/ltq-vdsl-app/files/dsl_notify.sh b/package/network/config/ltq-vdsl-app/files/dsl_notify.sh
deleted file mode 100644 (file)
index 0f1f535..0000000
+++ /dev/null
@@ -1,63 +0,0 @@
-#!/bin/sh
-#
-# This script is called by dsl_cpe_control whenever there is a DSL event,
-# we only actually care about the DSL_INTERFACE_STATUS events as these
-# tell us the line has either come up or gone down.
-#
-# The rest of the code is basically the same at the atm hotplug code
-#
-
-[ "$DSL_NOTIFICATION_TYPE" = "DSL_INTERFACE_STATUS" ] || exit 0
-
-. /usr/share/libubox/jshn.sh
-. /lib/functions.sh
-. /lib/functions/leds.sh
-
-include /lib/network
-scan_interfaces
-
-logger "Found no matching interface for DSL notification ($DSL_INTERFACE_STATUS)"
-
-local default
-config_load system
-config_get default led_adsl default
-if [ "$default" != 1 ]; then
-       case "$DSL_INTERFACE_STATUS" in
-         "HANDSHAKE")  led_timer adsl 500 500;;
-         "TRAINING")   led_timer adsl 200 200;;
-         "UP")         led_on adsl;;
-         *)            led_off adsl
-       esac
-fi
-
-local interfaces=`ubus list network.interface.\* | cut -d"." -f3`
-local ifc
-for ifc in $interfaces; do
-
-       local up
-       json_load "$(ifstatus $ifc)"
-       json_get_var up up
-
-       local auto
-       config_get_bool auto "$ifc" auto 1
-
-       local proto
-       json_get_var proto proto
-
-       if [ "$DSL_INTERFACE_STATUS" = "UP" ]; then
-               if [ "$proto" = "pppoa" ] && [ "$up" != 1 ] && [ "$auto" = 1 ]; then
-                       ( sleep 1; ifup "$ifc" ) &
-               fi
-       else
-               if [ "$proto" = "pppoa" ] && [ "$up" = 1 ] && [ "$auto" = 1 ]; then
-                       ( sleep 1; ifdown "$ifc" ) &
-               else
-                       json_get_var autostart autostart
-                       if [ "$proto" = "pppoa" ] && [ "$up" != 1 ] && [ "$autostart" = 1 ]; then
-                               ( sleep 1; ifdown "$ifc" ) &
-                       fi
-               fi
-       fi
-done
-
-
diff --git a/target/linux/lantiq/base-files/lib/functions/lantiq_dsl.sh b/target/linux/lantiq/base-files/lib/functions/lantiq_dsl.sh
new file mode 100644 (file)
index 0000000..e817fdd
--- /dev/null
@@ -0,0 +1,244 @@
+#!/bin/sh /etc/rc.common
+# Copyright (C) 2012 OpenWrt.org
+
+XDSL_CTRL=dsl_cpe_control
+
+#
+# Basic functions to send CLI commands to the vdsl_cpe_control daemon
+#
+dsl_cmd() {
+       killall -0 ${XDSL_CTRL} && (
+               echo "$@" > /tmp/pipe/dsl_cpe0_cmd
+               cat /tmp/pipe/dsl_cpe0_ack
+       )
+}
+dsl_val() {
+       echo $(expr "$1" : '.*'$2'=\([-\.[:alnum:]]*\).*')
+}
+
+#
+# Simple divide by 10 routine to cope with one decimal place
+#
+dbt() {
+       local a=$(expr $1 / 10)
+       local b=$(expr $1 % 10)
+       echo "${a}.${b}"
+}
+#
+# Take a number and convert to k or meg
+#
+scale() {
+       local val=$1
+       local a
+       local b
+
+       if [ "$val" -gt 1000000 ]; then
+               a=$(expr $val / 1000)
+               b=$(expr $a % 1000)
+               a=$(expr $a / 1000)
+               printf "%d.%03d Mb" ${a} ${b}
+       elif [ "$val" -gt 1000 ]; then
+               a=$(expr $val / 1000)
+               printf "%d Kb" ${a}
+       else
+               echo "${val} b"
+       fi
+}
+
+#
+# Read the data rates for both directions
+#
+data_rates() {
+       local csg
+       local dru
+       local drd
+       local sdru
+       local sdrd
+
+       csg=$(dsl_cmd g997csg 0 1)
+       drd=$(dsl_val "$csg" ActualDataRate)
+
+       csg=$(dsl_cmd g997csg 0 0)
+       dru=$(dsl_val "$csg" ActualDataRate)
+
+       [ -z "$drd" ] && drd=0
+       [ -z "$dru" ] && dru=0
+
+       sdrd=$(scale $drd)
+       sdru=$(scale $dru)
+
+       if [ "$action" = "lucistat" ]; then
+               echo "dsl.data_rate_down=$drd"
+               echo "dsl.data_rate_up=$dru"
+               echo "dsl.data_rate_down_s=\"$sdrd\""
+               echo "dsl.data_rate_up_s=\"$sdru\""
+       else
+               echo "Data Rate:                ${sdrd}/s / ${sdru}/s"
+       fi
+}
+
+#
+# Chipset
+#
+chipset() {
+       local vig
+       local cs
+       local csv
+
+       vig=$(dsl_cmd vig)
+       cs=$(dsl_val "$vig" DSL_ChipSetType)
+       csv=$(dsl_val "$vig" DSL_ChipSetHWVersion)
+
+       if [ "$action" = "lucistat" ]; then
+               echo "dsl.chipset=\"${cs} ${csv}\""
+       else
+               echo "Chipset:          ${cs} ${csv}"
+       fi
+}
+
+#
+# Work out how long the line has been up
+#
+line_uptime() {
+       local ccsg
+       local et
+       local etr
+       local d
+       local h
+       local m
+       local s
+       local rc=""
+
+       ccsg=$(dsl_cmd pmccsg 0 0 0)
+       et=$(dsl_val "$ccsg" nElapsedTime)
+
+       [ -z "$et" ] && et=0
+
+       if [ "$action" = "lucistat" ]; then
+               echo "dsl.line_uptime=${et}"
+               return
+       fi
+
+       d=$(expr $et / 86400)
+       etr=$(expr $et % 86400)
+       h=$(expr $etr / 3600)
+       etr=$(expr $etr % 3600)
+       m=$(expr $etr / 60)
+       s=$(expr $etr % 60)
+
+
+       [ "${d}${h}${m}${s}" -ne 0 ] && rc="${s}s"
+       [ "${d}${h}${m}" -ne 0 ] && rc="${m}m ${rc}"
+       [ "${d}${h}" -ne 0 ] && rc="${h}h ${rc}"
+       [ "${d}" -ne 0 ] && rc="${d}d ${rc}"
+
+       [ -z "$rc" ] && rc="down"
+       echo "Line Uptime:              ${rc}"
+}
+
+#
+# Get noise and attenuation figures
+#
+line_data() {
+       local lsg
+       local latnu
+       local latnd
+       local snru
+       local snrd
+
+       lsg=$(dsl_cmd g997lsg 1 1)
+       latnd=$(dsl_val "$lsg" LATN)
+       snrd=$(dsl_val "$lsg" SNR)
+
+       lsg=$(dsl_cmd g997lsg 0 1)
+       latnu=$(dsl_val "$lsg" LATN)
+       snru=$(dsl_val "$lsg" SNR)
+
+       [ -z "$latnd" ] && latnd=0
+       [ -z "$latnu" ] && latnu=0
+       [ -z "$snrd" ] && snrd=0
+       [ -z "$snru" ] && snru=0
+
+       latnd=$(dbt $latnd)
+       latnu=$(dbt $latnu)
+       snrd=$(dbt $snrd)
+       snru=$(dbt $snru)
+       
+       if [ "$action" = "lucistat" ]; then
+               echo "dsl.line_attenuation_down=$latnd"
+               echo "dsl.line_attenuation_up=$latnu"
+               echo "dsl.noise_margin_down=$snrd"
+               echo "dsl.noise_margin_up=$snru"
+       else
+               echo "Line Attenuation: ${latnd}dB / ${latnu}dB"
+               echo "Noise Margin:             ${snrd}dB / ${snru}dB"
+       fi
+}
+
+#
+# Is the line up? Or what state is it in?
+#
+line_state() {
+       local lsg=$(dsl_cmd lsg)
+       local ls=$(dsl_val "$lsg" nLineState);
+       local s;
+
+       case "$ls" in
+               "0x0")          s="not initialized" ;;
+               "0x1")          s="exception" ;;
+               "0x10")         s="not updated" ;;
+               "0xff")         s="idle request" ;;
+               "0x100")        s="idle" ;;
+               "0x1ff")        s="silent request" ;;
+               "0x200")        s="silent" ;;
+               "0x300")        s="handshake" ;;
+               "0x380")        s="full_init" ;;
+               "0x400")        s="discovery" ;;
+               "0x500")        s="training" ;;
+               "0x600")        s="analysis" ;;
+               "0x700")        s="exchange" ;;
+               "0x800")        s="showtime_no_sync" ;;
+               "0x801")        s="showtime_tc_sync" ;;
+               "0x900")        s="fastretrain" ;;
+               "0xa00")        s="lowpower_l2" ;;
+               "0xb00")        s="loopdiagnostic active" ;;
+               "0xb10")        s="loopdiagnostic data exchange" ;;
+               "0xb20")        s="loopdiagnostic data request" ;;
+               "0xc00")        s="loopdiagnostic complete" ;;
+               "0x1000000")    s="test" ;;
+               "0xd00")        s="resync" ;;
+               "0x3c0")        s="short init entry" ;;
+               "")             s="not running daemon"; ls="0xfff" ;;
+               *)              s="unknown" ;;
+       esac
+
+       if [ $action = "lucistat" ]; then
+               echo "dsl.line_state_num=$ls"
+               echo "dsl.line_state_detail=\"$s\""
+               if [ "$ls" = "0x801" ]; then
+                       echo "dsl.line_state=\"UP\""
+               else
+                       echo "dsl.line_state=\"DOWN\""
+               fi
+       else
+               if [ "$ls" = "0x801" ]; then
+                       echo "Line State:               UP [$ls: $s]"
+               else
+                       echo "Line State:               DOWN [$ls: $s]"
+               fi
+       fi
+}
+
+status() {
+       chipset
+       line_state
+       data_rates
+       line_data
+       line_uptime
+}
+
+lucistat() {
+       echo "local dsl={}"
+       status
+       echo "return dsl"
+}
diff --git a/target/linux/lantiq/base-files/sbin/dsl_notify.sh b/target/linux/lantiq/base-files/sbin/dsl_notify.sh
new file mode 100644 (file)
index 0000000..526a889
--- /dev/null
@@ -0,0 +1,61 @@
+#!/bin/sh
+#
+# This script is called by dsl_cpe_control whenever there is a DSL event,
+# we only actually care about the DSL_INTERFACE_STATUS events as these
+# tell us the line has either come up or gone down.
+#
+# The rest of the code is basically the same at the atm hotplug code
+#
+
+[ "$DSL_NOTIFICATION_TYPE" = "DSL_INTERFACE_STATUS" ] || exit 0
+
+. /usr/share/libubox/jshn.sh
+. /lib/functions.sh
+. /lib/functions/leds.sh
+
+include /lib/network
+scan_interfaces
+
+local default
+config_load system
+config_get default led_adsl default
+if [ "$default" != 1 ]; then
+       case "$DSL_INTERFACE_STATUS" in
+         "HANDSHAKE")  led_timer adsl 500 500;;
+         "TRAINING")   led_timer adsl 200 200;;
+         "UP")         led_on adsl;;
+         *)            led_off adsl
+       esac
+fi
+
+local interfaces=`ubus list network.interface.\* | cut -d"." -f3`
+local ifc
+for ifc in $interfaces; do
+
+       local up
+       json_load "$(ifstatus $ifc)"
+       json_get_var up up
+
+       local auto
+       config_get_bool auto "$ifc" auto 1
+
+       local proto
+       json_get_var proto proto
+
+       if [ "$DSL_INTERFACE_STATUS" = "UP" ]; then
+               if [ "$proto" = "pppoa" ] && [ "$up" != 1 ] && [ "$auto" = 1 ]; then
+                       ( sleep 1; ifup "$ifc" ) &
+               fi
+       else
+               if [ "$proto" = "pppoa" ] && [ "$up" = 1 ] && [ "$auto" = 1 ]; then
+                       ( sleep 1; ifdown "$ifc" ) &
+               else
+                       json_get_var autostart autostart
+                       if [ "$proto" = "pppoa" ] && [ "$up" != 1 ] && [ "$autostart" = 1 ]; then
+                               ( sleep 1; ifdown "$ifc" ) &
+                       fi
+               fi
+       fi
+done
+
+