allow a separate patch directory for host patches
authorFelix Fietkau <nbd@openwrt.org>
Sun, 22 Feb 2009 23:54:17 +0000 (23:54 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 22 Feb 2009 23:54:17 +0000 (23:54 +0000)
SVN-Revision: 14630

include/quilt.mk

index 77b76a6daee91d6dec0a2ff7e67942e68514486b..71fee06f14a36680ba4d93f054220ca20926bba9 100644 (file)
@@ -13,6 +13,8 @@ ifeq ($(TARGET_BUILD),1)
 endif
 PATCH_DIR?=./patches
 FILES_DIR?=./files
 endif
 PATCH_DIR?=./patches
 FILES_DIR?=./files
+HOST_PATCH_DIR?=$(PATCH_DIR)
+HOST_FILES_DIR?=$(FILES_DIR)
 
 ifeq ($(MAKECMDGOALS),refresh)
   override QUILT=1
 
 ifeq ($(MAKECMDGOALS),refresh)
   override QUILT=1
@@ -78,7 +80,7 @@ endif
 
 define Host/Patch/Default
        $(if $(QUILT),rm -rf $(HOST_BUILD_DIR)/patches; mkdir -p $(HOST_BUILD_DIR)/patches)
 
 define Host/Patch/Default
        $(if $(QUILT),rm -rf $(HOST_BUILD_DIR)/patches; mkdir -p $(HOST_BUILD_DIR)/patches)
-       $(call PatchDir,$(HOST_BUILD_DIR),$(PATCH_DIR),)
+       $(call PatchDir,$(HOST_BUILD_DIR),$(HOST_PATCH_DIR),)
        $(if $(QUILT),touch $(HOST_BUILD_DIR)/.quilt_used)
 endef
 
        $(if $(QUILT),touch $(HOST_BUILD_DIR)/.quilt_used)
 endef