build: change PYTHON to python3
authorFelix Fietkau <nbd@nbd.name>
Mon, 24 Jan 2022 10:22:31 +0000 (11:22 +0100)
committerFelix Fietkau <nbd@nbd.name>
Mon, 24 Jan 2022 12:29:05 +0000 (13:29 +0100)
On recent macOS, /usr/bin/python3 is a wrapper that finds the right python executable
It checks argv[0] to determine if python2 or python3 should be called. Always execute
it as python3 to ensure it calls the right version

Signed-off-by: Felix Fietkau <nbd@nbd.name>
rules.mk

index 57c3bca7d98c2448a80d467b6ead5cb62dd8de5a..8d4f61921192c92fd771800c092e1cc0cefff5be 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -274,7 +274,7 @@ BASH:=bash
 TAR:=tar
 FIND:=find
 PATCH:=patch
-PYTHON:=python
+PYTHON:=python3
 
 INSTALL_BIN:=install -m0755
 INSTALL_SUID:=install -m4755