kernel/modules: add kmod-crypto-seqiv
authorFelix Fietkau <nbd@openwrt.org>
Mon, 5 Jan 2015 13:01:42 +0000 (13:01 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 5 Jan 2015 13:01:42 +0000 (13:01 +0000)
Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
SVN-Revision: 43833

package/kernel/linux/modules/crypto.mk

index 04903c3781bab6ff9b2b4d94b16feff524068716..3193fb031a0726a9ceeb4367e95b3f63b9d16a64 100644 (file)
@@ -138,6 +138,17 @@ endef
 
 $(eval $(call KernelPackage,crypto-iv))
 
+define KernelPackage/crypto-seqiv
+  TITLE:=CryptoAPI Sequence Number IV Generator
+  DEPENDS:=+kmod-crypto-aead +kmod-crypto-rng
+  KCONFIG:=CONFIG_CRYPTO_SEQIV
+  FILES:=$(LINUX_DIR)/crypto/seqiv.ko
+  AUTOLOAD:=$(call AutoLoad,09,seqiv)
+  $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-seqiv))
+
 
 define KernelPackage/crypto-hw-talitos
   TITLE:=Freescale integrated security engine (SEC) driver