libpcap: add optional netfilter support
authorMartin Schiller <mschiller@tdt.de>
Mon, 20 Feb 2017 05:27:41 +0000 (06:27 +0100)
committerFelix Fietkau <nbd@nbd.name>
Wed, 22 Feb 2017 21:52:30 +0000 (22:52 +0100)
This is needed to use the nflog interface with tcpdump

Signed-off-by: Martin Schiller <mschiller@tdt.de>
package/libs/libpcap/Config.in
package/libs/libpcap/Makefile

index 05f45f4415920a8a99e8cd4b15bb26b2e332013f..11599273e79e924331860c50389ba71bae3a30fc 100644 (file)
@@ -10,4 +10,8 @@ config PCAP_HAS_BT
        depends on BROKEN
        default n
 
+config PCAP_HAS_NETFILTER
+       bool "Include netfilter support"
+       default n
+
 endmenu
index d3360d2dee124d5bb43e4996c67950ffe674a0f7..4d0ce4099343e64201597c0862e554b04ae15a68 100644 (file)
@@ -48,9 +48,12 @@ TARGET_CFLAGS += \
 
 CONFIGURE_VARS += \
        ac_cv_linux_vers=$(LINUX_VERSION) \
-       ac_cv_header_libusb_1_0_libusb_h=no \
-       ac_cv_netfilter_can_compile=no
+       ac_cv_header_libusb_1_0_libusb_h=no
 
+ifeq ($(CONFIG_PCAP_HAS_NETFILTER),)
+CONFIGURE_VARS += \
+       ac_cv_netfilter_can_compile=no
+endif
 
 CONFIGURE_ARGS += \
        --enable-shared \