ipq40xx: only include ath10k-board-qca4019 for the generic subtarget master
authorRobert Marko <robimarko@gmail.com>
Fri, 12 Nov 2021 12:17:10 +0000 (13:17 +0100)
committerChristian Lamparter <chunkeey@gmail.com>
Thu, 19 May 2022 14:39:54 +0000 (16:39 +0200)
Since MikroTik subtarget now uses dynamic BDF loading its crucial that it
doesnt include the board-2.bin at all which is provided by the
ath10k-board-qca4019 package.

So to resolve this include the ath10k-board-qca4019 package only for the
generic subtarget via its Makefile instead of via the target Makefile.

Signed-off-by: Robert Marko <robimarko@gmail.com>
target/linux/ipq40xx/Makefile
target/linux/ipq40xx/generic/target.mk

index 7df920e2d808ab9b3c2dbad8a12b178e87104f5b..19b63cdd65853ec13ae6762f4098efa811f3369f 100644 (file)
@@ -19,6 +19,6 @@ DEFAULT_PACKAGES += \
        kmod-leds-gpio kmod-gpio-button-hotplug swconfig \
        kmod-ath10k-ct wpad-basic-wolfssl \
        kmod-usb3 kmod-usb-dwc3 ath10k-firmware-qca4019-ct \
-       ath10k-board-qca4019 uboot-envtools
+       uboot-envtools
 
 $(eval $(call BuildTarget))
index e158b1c98b1065a8a7a47727d17113e60cbb491c..7867c30c23fcd0b12a9688141f276d12df9b87a0 100644 (file)
@@ -1,2 +1,4 @@
 BOARDNAME:=Generic
+
+DEFAULT_PACKAGES += ath10k-board-qca4019
 FEATURES+=emmc