kernel: prevent addition of scm marker to localversion
authorJosua Mayer <josua.mayer97@gmail.com>
Wed, 17 Aug 2016 14:09:46 +0000 (16:09 +0200)
committerJohn Crispin <john@phrozen.org>
Thu, 18 Aug 2016 07:49:18 +0000 (09:49 +0200)
When building the kernel from a git repository, the kernel build appends
either a + or a short commit hash to localversion.
This behaviour can be prevented by passing the empty LOCALVERSION variable
to make.

Signed-off-by: Josua Mayer <josua.mayer97@gmail.com>
include/kernel-defaults.mk

index 53e733adc0c24cd32f25b21d602565188f8545d2..47befbaab065b5ff2f02e794a94ad02de42a6585 100644 (file)
@@ -33,6 +33,10 @@ ifdef CONFIG_USE_SPARSE
   KERNEL_MAKEOPTS += C=1 CHECK=$(STAGING_DIR_HOST)/bin/sparse
 endif
 
+ifneq ($(strip $(CONFIG_KERNEL_GIT_CLONE_URI)),"")
+ KERNEL_MAKEOPTS += LOCALVERSION=
+endif
+
 export HOST_EXTRACFLAGS=-I$(STAGING_DIR_HOST)/include
 
 # defined in quilt.mk