archs38: Merge sd and ramfs subtargets in generic again
authorAlexey Brodkin <Alexey.Brodkin@synopsys.com>
Fri, 19 Aug 2016 10:58:36 +0000 (13:58 +0300)
committerJohn Crispin <john@phrozen.org>
Sat, 20 Aug 2016 03:33:47 +0000 (05:33 +0200)
As it turned out we may actually build both initramfs and
SD-based images in one run with just a small tweak in
existing image/Makefile and so we do here.

We're back with one "generic" target for all ARC HS38-based bords.

Kudos to John for his patience and very helpful tips!

Signed-off-by: John Crispin <john@phrozen.org>
Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com>
Cc: Jo-Philipp Wich <jo@mein.io>
target/linux/archs38/Makefile
target/linux/archs38/generic/profiles/00-default.mk [new file with mode: 0644]
target/linux/archs38/generic/target.mk [new file with mode: 0644]
target/linux/archs38/image/Makefile
target/linux/archs38/ramdisk/profiles/00-default.mk [deleted file]
target/linux/archs38/ramdisk/target.mk [deleted file]
target/linux/archs38/sd/profiles/00-default.mk [deleted file]
target/linux/archs38/sd/target.mk [deleted file]

index cbdbfba34a3462afb439a94a908c400740b623bc..166d3d554073c54ef2ae63fa603134c3c1f919aa 100644 (file)
@@ -11,7 +11,7 @@ CPU_TYPE:=archs
 BOARD:=archs38
 BOARDNAME:=Synopsys DesignWare ARC HS38
 MAINTAINER:=Alexey Brodkin <abrodkin@synopsys.com>
-SUBTARGETS:=sd ramdisk
+SUBTARGETS:=generic
 
 KERNEL_PATCHVER:=4.4
 
diff --git a/target/linux/archs38/generic/profiles/00-default.mk b/target/linux/archs38/generic/profiles/00-default.mk
new file mode 100644 (file)
index 0000000..fd8143a
--- /dev/null
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Default
+       NAME:=Default Profile (all drivers)
+       PACKAGES:= kmod-usb-core kmod-usb-ohci kmod-ath9k-htc wpad-mini
+endef
+
+define Profile/Default/Description
+       Default package set compatible with most boards.
+endef
+$(eval $(call Profile,Default))
diff --git a/target/linux/archs38/generic/target.mk b/target/linux/archs38/generic/target.mk
new file mode 100644 (file)
index 0000000..7642c6b
--- /dev/null
@@ -0,0 +1,8 @@
+BOARDNAME:=Generic
+FEATURES += ext4 usb ramdisk
+
+define Target/Description
+       Build firmware images for ARC HS38 based boards.
+endef
+
+
index 505ed0262540b7911936184b70ae63ba1e6f6929..14f6bc3db4fc478509366ebbd226c2e6573fec9a 100644 (file)
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/image.mk
 # in memory from build to built. Thus we need to extract EP from vmlinux
 # every time before generation of uImage.
 define Build/calculate-ep
-       $(eval KERNEL_ENTRY=$(shell $(KERNEL_CROSS)readelf -h $(LINUX_DIR)/vmlinux | grep "Entry point address" | grep -o 0x.*))
+       $(eval KERNEL_ENTRY=$(shell $(KERNEL_CROSS)readelf -h $(1) | grep "Entry point address" | grep -o 0x.*))
 endef
 
 define Build/build-dtb
@@ -36,7 +36,8 @@ define Device/nsim_hs
        DEVICE_DTS := nsim_hs_idu
 endef
 TARGET_DEVICES += nsim_hs
-else
+endif
+
 # Root FS on SD-card
 KERNEL_LOADADDR := 0x80000000
 DEVICE_DTS_LIST:= axs103_idu
@@ -65,7 +66,7 @@ endef
 
 define Image/BuildKernel
        # Build unified uImage
-       $(call Build/calculate-ep)
+       $(call Build/calculate-ep, $(KDIR)/vmlinux.elf)
        $(call Image/BuildKernel/MkuImage, \
                none, $(KERNEL_LOADADDR), $(KERNEL_ENTRY), \
                $(KDIR)/vmlinux, \
@@ -81,6 +82,5 @@ define Image/Build
        $(call Image/Build/SDCard,$(1))
        dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
 endef
-endif
 
 $(eval $(call BuildImage))
diff --git a/target/linux/archs38/ramdisk/profiles/00-default.mk b/target/linux/archs38/ramdisk/profiles/00-default.mk
deleted file mode 100644 (file)
index 4d86da3..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
-#
-# Copyright (C) 2016 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Default
-       NAME:=Default Profile (all drivers)
-endef
-
-define Profile/Default/Description
-       Default package set compatible with most boards.
-endef
-$(eval $(call Profile,Default))
diff --git a/target/linux/archs38/ramdisk/target.mk b/target/linux/archs38/ramdisk/target.mk
deleted file mode 100644 (file)
index 8612d32..0000000
+++ /dev/null
@@ -1,8 +0,0 @@
-BOARDNAME:=Ramdisk
-FEATURES += ramdisk
-
-define Target/Description
-       Build firmware images for generic ARC HS38 based boards that use built-in initramfs
-endef
-
-
diff --git a/target/linux/archs38/sd/profiles/00-default.mk b/target/linux/archs38/sd/profiles/00-default.mk
deleted file mode 100644 (file)
index fd8143a..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
-#
-# Copyright (C) 2016 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Default
-       NAME:=Default Profile (all drivers)
-       PACKAGES:= kmod-usb-core kmod-usb-ohci kmod-ath9k-htc wpad-mini
-endef
-
-define Profile/Default/Description
-       Default package set compatible with most boards.
-endef
-$(eval $(call Profile,Default))
diff --git a/target/linux/archs38/sd/target.mk b/target/linux/archs38/sd/target.mk
deleted file mode 100644 (file)
index ca4f191..0000000
+++ /dev/null
@@ -1,8 +0,0 @@
-BOARDNAME:=SD
-FEATURES += ext4 usb
-
-define Target/Description
-       Build firmware images for ARC HS38 based boards that use SD-card for booting.
-endef
-
-