imx6: fix generating bootfs in imagebuilder (FS#102)
authorJo-Philipp Wich <jo@mein.io>
Sat, 20 Aug 2016 18:17:51 +0000 (20:17 +0200)
committerJo-Philipp Wich <jo@mein.io>
Sat, 20 Aug 2016 18:23:32 +0000 (20:23 +0200)
The image builder does not bundle sub-directories within $(KERNEL_BUILD_DIR),
therfore the intermediate "ventana-uImage.boot" directory is not shipped,
leading to failures with "make image" later on.

To circumvent the issue, store the intermediate boot files as tar archive
instead of putting them into a directory to ensure that they end up in the
final image builder tarball. Fixes FS#102

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
target/linux/imx6/image/Makefile

index 2181ea5db41fc4239569a46ce35e8525e04ddf51..6b66376d41163ebc1195edb80b955ff65f9a7d90 100644 (file)
@@ -37,10 +37,16 @@ define Build/boot-overlay
                --space-fixup --force-compr=zlib --squash-uids \
                $(MKUBIFS_OPTS) -c 8124 \
                -o $@.boot.ubifs -d $@.boot
+
+       $(TAR) -C $@.boot -cf $@.boot.tar .
 endef
 
 define Build/bootfs.tar.gz
-       $(TAR) -C $(IMAGE_KERNEL).boot \
+       rm -rf $@.boot
+       mkdir -p $@.boot
+
+       $(TAR) -C $@.boot -xf $(IMAGE_KERNEL).boot.tar
+       $(TAR) -C $@.boot \
                --numeric-owner --owner=0 --group=0 --transform "s,./,./boot/," \
                -czvf $@ .
 endef