kernel: bump 4.14 to 4.14.108
[openwrt/staging/dedeckeh.git] / include / quilt.mk
index 77b76a6daee91d6dec0a2ff7e67942e68514486b..56f674a2f39e490b4574b85266b0e6f350a0a284 100644 (file)
@@ -1,23 +1,46 @@
-# 
+#
 # Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
-#
-
-ifneq ($(__quilt_inc),1)
-__quilt_inc:=1
 
 ifeq ($(TARGET_BUILD),1)
   PKG_BUILD_DIR:=$(LINUX_DIR)
 endif
-PATCH_DIR?=./patches
-FILES_DIR?=./files
 
-ifeq ($(MAKECMDGOALS),refresh)
+ifneq ($(filter host-refresh refresh,$(MAKECMDGOALS)),)
   override QUILT=1
+  override HOST_QUILT=1
 endif
 
+ifneq ($(PKG_BUILD_DIR),)
+  QUILT?=$(if $(wildcard $(PKG_BUILD_DIR)/.quilt_used),y)
+  ifneq ($(QUILT),)
+    STAMP_CHECKED:=$(PKG_BUILD_DIR)/.quilt_checked
+    override CONFIG_AUTOREBUILD=
+    override CONFIG_AUTOREMOVE=
+    quilt-check: $(STAMP_CHECKED)
+  endif
+endif
+
+ifneq ($(HOST_BUILD_DIR),)
+  HOST_QUILT?=$(if $(findstring command,$(origin QUILT)),$(QUILT),$(if $(wildcard $(HOST_BUILD_DIR)/.quilt_used),y))
+  ifneq ($(HOST_QUILT),)
+    HOST_STAMP_CHECKED:=$(HOST_BUILD_DIR)/.quilt_checked
+    override CONFIG_AUTOREBUILD=
+    override CONFIG_AUTOREMOVE=
+    host-quilt-check: $(HOST_STAMP_CHECKED)
+  endif
+endif
+
+ifneq ($(if $(DUMP),1,$(__quilt_inc)),1)
+__quilt_inc:=1
+
+PATCH_DIR?=./patches
+FILES_DIR?=./files
+HOST_PATCH_DIR?=$(PATCH_DIR)
+HOST_FILES_DIR?=$(FILES_DIR)
+
 QUILT_CMD:=quilt --quiltrc=-
 
 define filter_series
@@ -25,27 +48,26 @@ sed -e s,\\\#.*,, $(1) | grep -E \[a-zA-Z0-9\]
 endef
 
 define PatchDir/Quilt
+       @mkdir -p "$(1)/patches$(if $(3),/$(patsubst %/,%,$(3)))"
        @if [ -s "$(2)/series" ]; then \
                mkdir -p "$(1)/patches/$(3)"; \
                cp "$(2)/series" "$(1)/patches/$(3)"; \
        fi
-       @for patch in $$$$( (cd "$(2)" && if [ -f series ]; then $(call filter_series,series); else ls; fi; ) 2>/dev/null ); do ( \
-               cp "$(2)/$$$$patch" "$(1)"; \
-               cd "$(1)"; \
-               $(QUILT_CMD) import -P$(3)$$$$patch -p 1 "$$$$patch"; \
-               $(QUILT_CMD) push -f >/dev/null 2>/dev/null; \
-               rm -f "$$$$patch"; \
+       @for patch in $$$$( (cd "$(2)" && if [ -f series ]; then $(call filter_series,series); else ls | sort; fi; ) 2>/dev/null ); do ( \
+               cp "$(2)/$$$$patch" "$(1)/patches/$(3)"; \
+               echo "$(3)$$$$patch" >> "$(1)/patches/series"; \
        ); done
        $(if $(3),@echo $(3) >> "$(1)/patches/.subdirs")
 endef
 
 define PatchDir/Default
-       @if [ -d "$(2)" -a "$$$$(ls $(2) | wc -l)" -gt 0 ]; then \
+       @if [ -d "$(2)" ] && [ "$$$$(ls $(2) | wc -l)" -gt 0 ]; then \
+               export PATCH="$(PATCH)"; \
                if [ -s "$(2)/series" ]; then \
                        $(call filter_series,$(2)/series) | xargs -n1 \
-                               $(PATCH) "$(1)" "$(2)"; \
+                               $(KPATCH) "$(1)" "$(2)"; \
                else \
-                       $(PATCH) "$(1)" "$(2)"; \
+                       $(KPATCH) "$(1)" "$(2)"; \
                fi; \
        fi
 endef
@@ -54,32 +76,14 @@ define PatchDir
 $(call PatchDir/$(if $(strip $(QUILT)),Quilt,Default),$(strip $(1)),$(strip $(2)),$(strip $(3)))
 endef
 
-ifneq ($(PKG_BUILD_DIR),)
-  QUILT?=$(strip $(shell test -f $(PKG_BUILD_DIR)/.quilt_used && echo y))
-  ifneq ($(QUILT),)
-    STAMP_PATCHED:=$(PKG_BUILD_DIR)/.quilt_patched
-    STAMP_CHECKED:=$(PKG_BUILD_DIR)/.quilt_checked
-    override CONFIG_AUTOREBUILD=
-    prepare: $(STAMP_PATCHED)
-    quilt-check: $(STAMP_CHECKED)
-  endif
-endif
-
-ifneq ($(HOST_BUILD_DIR),)
-  HOST_QUILT?=$(strip $(shell test -f $(if $(PKG_BUILD_DIR),$(PKG_BUILD_DIR),$(HOST_BUILD_DIR))/.quilt_used && echo y))
-  ifneq ($(HOST_QUILT),)
-    HOST_STAMP_PATCHED:=$(HOST_BUILD_DIR)/.quilt_patched
-    HOST_STAMP_CHECKED:=$(HOST_BUILD_DIR)/.quilt_checked
-    override CONFIG_AUTOREBUILD=
-    host-prepare: $(HOST_STAMP_PATCHED)
-    host-quilt-check: $(HOST_STAMP_CHECKED)
-  endif
-endif
+define HostPatchDir
+$(call PatchDir/$(if $(strip $(HOST_QUILT)),Quilt,Default),$(strip $(1)),$(strip $(2)),$(strip $(3)))
+endef
 
 define Host/Patch/Default
-       $(if $(QUILT),rm -rf $(HOST_BUILD_DIR)/patches; mkdir -p $(HOST_BUILD_DIR)/patches)
-       $(call PatchDir,$(HOST_BUILD_DIR),$(PATCH_DIR),)
-       $(if $(QUILT),touch $(HOST_BUILD_DIR)/.quilt_used)
+       $(if $(HOST_QUILT),rm -rf $(HOST_BUILD_DIR)/patches; mkdir -p $(HOST_BUILD_DIR)/patches)
+       $(call HostPatchDir,$(HOST_BUILD_DIR),$(HOST_PATCH_DIR),)
+       $(if $(HOST_QUILT),touch $(HOST_BUILD_DIR)/.quilt_used)
 endef
 
 define Build/Patch/Default
@@ -90,19 +94,25 @@ endef
 
 kernel_files=$(foreach fdir,$(GENERIC_FILES_DIR) $(FILES_DIR),$(fdir)/.)
 define Kernel/Patch/Default
-       rm -rf $(PKG_BUILD_DIR)/patches; mkdir -p $(PKG_BUILD_DIR)/patches
+       $(if $(QUILT),rm -rf $(LINUX_DIR)/patches; mkdir -p $(LINUX_DIR)/patches)
        $(if $(kernel_files),$(CP) $(kernel_files) $(LINUX_DIR)/)
        find $(LINUX_DIR)/ -name \*.rej -or -name \*.orig | $(XARGS) rm -f
-       $(call PatchDir,$(PKG_BUILD_DIR),$(GENERIC_PATCH_DIR),generic/)
-       $(call PatchDir,$(PKG_BUILD_DIR),$(PATCH_DIR),platform/)
+       if [ -d $(GENERIC_PLATFORM_DIR)/patches$(if $(wildcard $(GENERIC_PLATFORM_DIR)/patches-$(KERNEL_PATCHVER)),-$(KERNEL_PATCHVER)) ]; then \
+               echo "generic patches directory is present. please move your patches to the pending directory" ; \
+               exit 1; \
+       fi
+       $(call PatchDir,$(LINUX_DIR),$(GENERIC_BACKPORT_DIR),generic-backport/)
+       $(call PatchDir,$(LINUX_DIR),$(GENERIC_PATCH_DIR),generic/)
+       $(call PatchDir,$(LINUX_DIR),$(GENERIC_HACK_DIR),generic-hack/)
+       $(call PatchDir,$(LINUX_DIR),$(PATCH_DIR),platform/)
 endef
 
 define Quilt/RefreshDir
        mkdir -p $(2)
        -rm -f $(2)/* 2>/dev/null >/dev/null
        @( \
-               for patch in $$$$($(if $(3),grep "^$(3)",cat) $(PKG_BUILD_DIR)/patches/series | awk '{print $$$$1}'); do \
-                       $(CP) -v "$(PKG_BUILD_DIR)/patches/$$$$patch" $(2); \
+               for patch in $$$$($(if $(3),grep "^$(3)",cat) $(1)/patches/series | awk '{print $$$$1}'); do \
+                       $(CP) -v "$(1)/patches/$$$$patch" $(2); \
                done; \
        )
 endef
@@ -120,34 +130,16 @@ define Quilt/Refresh/Kernel
                echo "All kernel patches must start with either generic/ or platform/"; \
                false; \
        }
+       $(call Quilt/RefreshDir,$(PKG_BUILD_DIR),$(GENERIC_BACKPORT_DIR),generic-backport/)
        $(call Quilt/RefreshDir,$(PKG_BUILD_DIR),$(GENERIC_PATCH_DIR),generic/)
+       $(call Quilt/RefreshDir,$(PKG_BUILD_DIR),$(GENERIC_HACK_DIR),generic-hack/)
        $(call Quilt/RefreshDir,$(PKG_BUILD_DIR),$(PATCH_DIR),platform/)
 endef
 
 define Quilt/Template
-  $($(2)STAMP_PATCHED): $($(2)STAMP_PREPARED)
-       @( \
-               cd $(1)/patches; \
-               $(QUILT_CMD) pop -a -f >/dev/null 2>/dev/null; \
-               if [ -s ".subdirs" ]; then \
-                       rm -f series; \
-                       for file in $$$$(cat .subdirs); do \
-                               if [ -f $$$$file/series ]; then \
-                                       echo "Converting $$file/series"; \
-                                       $$(call filter_series,$$$$file/series) | awk -v file="$$$$file/" '$$$$0 !~ /^#/ { print file $$$$0 }' | sed -e s,//,/,g >> series; \
-                               else \
-                                       echo "Sorting patches in $$$$file"; \
-                                       find $$$$file/* -type f \! -name series | sed -e s,//,/,g | sort >> series; \
-                               fi; \
-                       done; \
-               else \
-                       find * -type f \! -name series | sort > series; \
-               fi; \
-       )
-       touch "$$@"
-
-  $($(2)STAMP_CONFIGURED): $($(2)STAMP_CHECKED) FORCE
-  $($(2)STAMP_CHECKED): $($(2)STAMP_PATCHED)
+  $($(2)STAMP_CONFIGURED): $($(2)STAMP_CHECKED)
+  $(if $(NO_RECONFIGURE),$($(2)STAMP_BUILT),$($(2)STAMP_CONFIGURED)): FORCE
+  $($(2)STAMP_CHECKED): $($(2)STAMP_PREPARED)
        if [ -s "$(1)/patches/series" ]; then \
                (cd "$(1)"; \
                        if $(QUILT_CMD) next >/dev/null 2>&1; then \
@@ -168,7 +160,8 @@ define Quilt/Template
                echo "The source directory contains no quilt patches."; \
                false; \
        }
-       @[ -n "$$$$(ls $(1)/patches/series)" -o "$$$$(cat $(1)/patches/series | md5sum)" = "$$(sort $(1)/patches/series | md5sum)" ] || { \
+       @[ -n "$$$$(ls $(1)/patches/series)" -o \
+          "$$$$(cat $(1)/patches/series | mkhash md5)" = "$$(sort $(1)/patches/series | mkhash md5)" ] || { \
                echo "The patches are not sorted in the right order. Please fix."; \
                false; \
        }