kernel: bump 4.14 to 4.14.108
[openwrt/staging/dedeckeh.git] / include / rootfs.mk
index a3a08c2851cd0a377e36284c69e1518e94b694cc..dc8621dbae4df62e6d73c208b42b1e0a925e1708 100644 (file)
@@ -1,5 +1,3 @@
-include $(INCLUDE_DIR)/feeds.mk
-
 ifdef CONFIG_USE_MKLIBS
   define mklibs
        rm -rf $(TMP_DIR)/mklibs-progs $(TMP_DIR)/mklibs-out
@@ -63,9 +61,9 @@ ifdef CONFIG_CLEAN_IPKG
 endif
 
 define prepare_rootfs
-       @if [ -d $(TOPDIR)/files ]; then \
-               $(call file_copy,$(TOPDIR)/files/.,$(1)); \
-       fi
+       $(if $(2),@if [ -d '$(2)' ]; then \
+               $(call file_copy,$(2)/.,$(1)); \
+       fi)
        @mkdir -p $(1)/etc/rc.d
        @mkdir -p $(1)/var/lock
        @( \
@@ -92,6 +90,7 @@ define prepare_rootfs
        rm -f $(1)/usr/lib/opkg/lists/*
        rm -f $(1)/usr/lib/opkg/info/*.postinst*
        rm -f $(1)/var/lock/*.lock
+       rm -rf $(1)/boot
        $(call clean_ipkg,$(1))
        $(call mklibs,$(1))
 endef