remove sed test garbage left behind on some hosts with an old/unsupported sed
[openwrt/staging/dedeckeh.git] / openwrt / Makefile
index a554a1d867fd3cd04d8aafc9e639e6f498a17e77..39ffb17fb5e770c8c6983feee5ef3568388665a2 100644 (file)
@@ -1,20 +1,10 @@
 # Makefile for OpenWrt
 #
+# Copyright (C) 2006 OpenWrt.org
 # Copyright (C) 2006 by Felix Fietkau <openwrt@nbd.name>
 #
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
 #
 
 RELEASE:=Kamikaze
@@ -24,93 +14,128 @@ RELEASE:=Kamikaze
 # Just run 'make menuconfig', configure stuff, then run 'make'.
 # You shouldn't need to mess with anything beyond this point...
 #--------------------------------------------------------------
-TOPDIR=${shell pwd}
-export TOPDIR
+
+all: world
+
+SHELL:=/usr/bin/env bash
+export TOPDIR=${shell pwd}
 include $(TOPDIR)/include/verbose.mk
 
 OPENWRTVERSION:=$(RELEASE)
 ifneq ($(VERSION),)
-OPENWRTVERSION:=$(VERSION) ($(OPENWRTVERSION))
+  OPENWRTVERSION:=$(VERSION) ($(OPENWRTVERSION))
 else
-REV:=$(shell LANG=C svn info | awk '/^Revision:/ { print$$2 }' )
-ifneq ($(REV),)
-OPENWRTVERSION:=$(OPENWRTVERSION)/r$(REV)
-endif
+  REV:=$(shell LANG=C svn info | awk '/^Revision:/ { print$$2 }' )
+  ifneq ($(REV),)
+    OPENWRTVERSION:=$(OPENWRTVERSION)/r$(REV)
+  endif
 endif
 export OPENWRTVERSION
 
-all: world
-
-.pkginfo: FORCE
 ifneq ($(shell ./scripts/timestamp.pl -p .pkginfo package Makefile),.pkginfo)
+  .pkginfo .config: FORCE
+endif
+
+ifeq ($(FORCE),)
+  .config scripts/config/conf scripts/config/mconf: .prereq-build
+  world: .prereq-packages
+endif
+
+.pkginfo:
        @echo Collecting package info...
        @-for dir in package/*/; do \
                echo Source-Makefile: $${dir}Makefile; \
-               $(MAKE) --no-print-dir DUMP=1 -C $$dir 2>&- || true; \
+               $(NO_TRACE_MAKE) --no-print-dir DUMP=1 -C $$dir || echo "ERROR: please fix $${dir}Makefile" >&2; \
        done > $@
-endif
-
-.config.in: .pkginfo
-       ./scripts/gen_menuconfig.pl < $< > $@ || rm -f $@
 
 pkginfo-clean: FORCE
        -rm -f .pkginfo .config.in
 
-./scripts/config/mconf: .config.in
-       $(MAKE) -C scripts/config all
+.config.in: .pkginfo
+       @./scripts/gen_menuconfig.pl < $< > $@ || rm -f $@
+
+.config: ./scripts/config/conf .config.in
+       @[ -f .config ] || $(NO_TRACE_MAKE) menuconfig
+       @$< -D .config Config.in &> /dev/null
+
+scripts/config/mconf:
+       @$(MAKE) -C scripts/config all
 
-./scripts/config/conf: .config.in
-       $(MAKE) -C scripts/config conf
+scripts/config/conf:
+       @$(MAKE) -C scripts/config conf
 
-config: ./scripts/config/conf FORCE
+config: scripts/config/conf .config.in FORCE
        $< Config.in
 
-defconfig: ./scripts/config/conf FORCE
+config-clean: FORCE
+       $(NO_TRACE_MAKE) -C scripts/config clean
+
+defconfig: scripts/config/conf .config.in FORCE
        touch .config
        $< -D .config Config.in
 
-oldconfig: ./scripts/config/conf FORCE
+oldconfig: scripts/config/conf .config.in FORCE
        $< -o Config.in
 
-menuconfig: ./scripts/config/mconf FORCE
+menuconfig: scripts/config/mconf .config.in FORCE
        $< Config.in
 
-config-clean: FORCE
-       $(MAKE) -C scripts/config clean
-
 package/%: .pkginfo FORCE
        $(MAKE) -C package $(patsubst package/%,%,$@)
 
 target/%: .pkginfo FORCE
        $(MAKE) -C target $(patsubst target/%,%,$@)
 
+tools/%: FORCE
+       $(MAKE) -C tools $(patsubst tools/%,%,$@)
+
 toolchain/%: FORCE
        $(MAKE) -C toolchain $(patsubst toolchain/%,%,$@)
 
-.config: ./scripts/config/conf FORCE
-       @[ -f .config ] || $(MAKE) menuconfig
-       $< -D .config Config.in >/dev/null 2>/dev/null
+.prereq-build: include/prereq-build.mk
+       @$(NO_TRACE_MAKE) -s -f $(TOPDIR)/include/prereq-build.mk prereq 2>/dev/null || { \
+               echo "Prerequisite check failed. Use FORCE=1 to override."; \
+               rm -rf $(TOPDIR)/tmp; \
+               false; \
+       }
+       @rm -rf $(TOPDIR)/tmp
+       @touch $@
+
+.prereq-packages: include/prereq.mk .pkginfo .config
+       @$(NO_TRACE_MAKE) -s -C package prereq 2>/dev/null || { \
+               echo "Prerequisite check failed. Use FORCE=1 to override."; \
+               false; \
+       }
+       @rm -rf "$(TOPDIR)/tmp"
+       @touch $@
+       
+prereq: .prereq-build .prereq-packages FORCE
 
 download: .config FORCE
+       $(MAKE) tools/download
        $(MAKE) toolchain/download
        $(MAKE) package/download
        $(MAKE) target/download
 
 world: .config FORCE
+       $(MAKE) tools/install
        $(MAKE) toolchain/install
        $(MAKE) target/compile
        $(MAKE) package/compile
        $(MAKE) package/install
        $(MAKE) target/install
+       $(MAKE) package/index
 
 clean: FORCE
        rm -rf build_* bin
 
 dirclean: clean
-       rm -rf staging_dir_* toolchain_build_*
+       rm -rf staging_dir_* toolchain_build_* tool_build
 
 distclean: dirclean config-clean
-       rm -rf dl .*config* .pkg*
+       rm -rf dl .*config* .pkg* .prereq 
 
+.SILENT: clean dirclean distclean config-clean download world
+FORCE: ;
 .PHONY: FORCE
-FORCE:
+%: ;