replace ipkg-make-index with a shell script that works on bsd
[openwrt/staging/dedeckeh.git] / openwrt / rules.mk
index eebc758224c6d811f761cbf6fb6470e05623fb0a..b9859dbd3f66e9b653e56331a9ed05319d8fc341 100644 (file)
@@ -8,7 +8,8 @@
 -include $(TOPDIR)/.config
 include $(TOPDIR)/include/verbose.mk
 
-export SHELL=/bin/bash
+export SHELL=/usr/bin/env bash -c '. $(TOPDIR)/include/shell.sh; eval "$$2"' --
+export BASH=$(shell which bash)
 
 ARCH:=$(strip $(subst ",, $(CONFIG_ARCH)))
 TARGET_OPTIMIZATION:=$(strip $(subst ",, $(CONFIG_TARGET_OPTIMIZATION)))
@@ -60,25 +61,10 @@ CP:=cp -fpR
 
 ifneq ($(CONFIG_CCACHE),)
   # FIXME: move this variable to a better location
-  export CCACHE_DIR=$(TOPDIR)/ccache_$(ARCH)
+  export CCACHE_DIR=$(STAGING_DIR)/ccache
   TARGET_CC:= ccache $(TARGET_CC)
 endif
 
-HOST_ARCH:=$(shell $(HOSTCC) -dumpmachine | sed -e s'/-.*//' \
-       -e 's/sparc.*/sparc/' \
-       -e 's/arm.*/arm/' \
-       -e 's/m68k.*/m68k/' \
-       -e 's/ppc/powerpc/' \
-       -e 's/v850.*/v850/' \
-       -e 's/sh[234]/sh/' \
-       -e 's/mips-.*/mips/' \
-       -e 's/mipsel-.*/mipsel/' \
-       -e 's/cris.*/cris/' \
-       -e 's/i[3-9]86/i386/' \
-       )
-
-GNU_HOST_NAME:=$(shell $(HOSTCC) -dumpmachine)
-
 TARGET_CONFIGURE_OPTS:= \
   AR=$(TARGET_CROSS)ar \
   AS="$(TARGET_CC) -c $(TARGET_CFLAGS)" \