add grub based images for x86-2.6 - still a bit hackish, but works with ext2 and...
[openwrt/staging/dedeckeh.git] / openwrt / target / Makefile
index 52b2e60cff76e536cd65679e63bb65a17f6258a1..195878e6654d0e4c8fd35f50ceb14b07873c9891 100644 (file)
@@ -1,33 +1,49 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 include $(TOPDIR)/rules.mk
-
-# Default target skeleton stuff, may be overridden
-TARGET_SKEL_DIR=default/target_skeleton
+include $(INCLUDE_DIR)/target.mk
 
 all: install
 
 $(BIN_DIR):
        mkdir -p $(BIN_DIR)
 
-linux-compile: utils-install lzma-install
+TARGETS-y := linux utils
+TARGETS-$(CONFIG_SDK) += sdk
+
+linux-compile: utils-install
 linux-install: $(BIN_DIR)
+sdk-compile: linux-install
+image_install: linux-install
 
-prepare: 
-compile: linux-compile
-install: image_clean linux-install
-clean: linux-clean utils-clean lzma-clean image_clean
+download: $(patsubst %,%-download,$(TARGETS-y))
+prepare: linux-prepare
+compile: linux-compile image_compile
+install: image_clean $(patsubst %,%-install,$(TARGETS-y)) image_install
+clean: $(patsubst %,%-clean,$(TARGETS-y)) image_clean
 
-image_clean:
+image_clean: FORCE
+       $(MAKE) -C image/$(BOARD) clean
        rm -f $(BIN_DIR)/openwrt-*
+       
+image_compile: FORCE
+       $(MAKE) -C image/$(BOARD) compile
 
-%-clean:
+image_install: image_compile
+       $(MAKE) -C image/$(BOARD) install
+
+%-clean: FORCE
        $(MAKE) -C $(patsubst %-clean,%,$@) clean
-%-prepare:
+%-download: FORCE
+       $(MAKE) -C $(patsubst %-download,%,$@) download
+%-prepare: FORCE
        $(MAKE) -C $(patsubst %-prepare,%,$@) prepare
 %-compile: %-prepare
        $(MAKE) -C $(patsubst %-compile,%,$@) compile
-%-rebuild: 
-       $(MAKE) -C $(patsubst %-rebuild,%,$@) rebuild
 %-install: %-compile
        $(MAKE) -C $(patsubst %-install,%,$@) install
 
-