add a flag "IGNORE_ERRORS", which can be used to ignore build errors in packages
[openwrt/staging/dedeckeh.git] / package / Makefile
index e618a90b698795d53a5d1b87cccf6b084cbb7d86..a1f20b0b1633ddd119d440b8844b3cd06c72633b 100644 (file)
@@ -17,6 +17,9 @@ else
   $(curdir)/builddirs-prereq:=. $(sort $(prereq-y) $(prereq-m))
   $(curdir)/builddirs-install:=. $(sort $(package-y))
 endif
+ifneq ($(IGNORE_ERRORS),)
+  $(curdir)/builddirs-ignore-compile:= $(if $(filter m y, $(IGNORE_ERRORS)),$(foreach m,$(IGNORE_ERRORS),$(package-$(m))),$(package-m))
+endif
 
 $(curdir)/install:=$(curdir)/install-cleanup