license info - revert r43155
[openwrt/staging/dedeckeh.git] / package / boot / kexec-tools / Makefile
index 541dca275ad09d45ddb83f561cde74a590bfb823..8c1c255cbabce2cba867e58a1f36cb786da37571 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=kexec-tools
-PKG_VERSION:=2.0.3
+PKG_VERSION:=2.0.4
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@KERNEL/linux/utils/kernel/kexec
-PKG_MD5SUM:=b3ced2097ce3981abba38ceedc84f939
+PKG_MD5SUM:=05992bc8c0673fc55be7b6d27e48a8db
 
 PKG_FIXUP:=autoreconf
 
@@ -54,7 +54,11 @@ CONFIGURE_ARGS = \
                --sbindir=/usr/sbin \
                --libexecdir=/usr/lib \
                --sysconfdir=/etc \
-               $(if $(CONFIG_KEXEC_ZLIB),--with,--without)-zlib
+               $(if $(CONFIG_KEXEC_ZLIB),--with,--without)-zlib \
+               --without-lzma
+
+TARGET_CFLAGS += -ffunction-sections -fdata-sections
+TARGET_LDFLAGS += -Wl,--gc-sections
 
 CONFIGURE_VARS += \
        BUILD_CC="$(HOSTCC)" \