libpcap: add optional netfilter support
[openwrt/staging/dedeckeh.git] / package / libs / libpcap / Makefile
index d3360d2dee124d5bb43e4996c67950ffe674a0f7..4d0ce4099343e64201597c0862e554b04ae15a68 100644 (file)
@@ -48,9 +48,12 @@ TARGET_CFLAGS += \
 
 CONFIGURE_VARS += \
        ac_cv_linux_vers=$(LINUX_VERSION) \
-       ac_cv_header_libusb_1_0_libusb_h=no \
-       ac_cv_netfilter_can_compile=no
+       ac_cv_header_libusb_1_0_libusb_h=no
 
+ifeq ($(CONFIG_PCAP_HAS_NETFILTER),)
+CONFIGURE_VARS += \
+       ac_cv_netfilter_can_compile=no
+endif
 
 CONFIGURE_ARGS += \
        --enable-shared \