hostapd: update to version 2016-09-05
[openwrt/staging/dedeckeh.git] / package / network / services / hostapd / patches / 600-ubus_support.patch
index 04af5da7deeaa04a3715db587388163536cb3723..ab13601f01062f6937355e53ae098ebf12453149 100644 (file)
@@ -1,6 +1,6 @@
 --- a/hostapd/Makefile
 +++ b/hostapd/Makefile
-@@ -105,6 +105,11 @@ OBJS += ../src/common/wpa_common.o
+@@ -160,6 +160,11 @@ OBJS += ../src/common/hw_features_common
  
  OBJS += ../src/eapol_auth/eapol_auth_sm.o
  
 +LIBS += -lubox -lubus
 +endif
  
- ifndef CONFIG_NO_DUMP_STATE
- # define HOSTAPD_DUMP_STATE to include SIGUSR1 handler for dumping state to
+ ifdef CONFIG_CODE_COVERAGE
+ CFLAGS += -O0 -fprofile-arcs -ftest-coverage
 --- a/src/ap/hostapd.h
 +++ b/src/ap/hostapd.h
-@@ -11,6 +11,7 @@
- #include "common/defs.h"
+@@ -13,6 +13,7 @@
+ #include "utils/list.h"
  #include "ap_config.h"
+ #include "drivers/driver.h"
 +#include "ubus.h"
  
- struct wpa_driver_ops;
  struct wpa_ctrl_dst;
-@@ -105,6 +106,7 @@ struct hostapd_data {
+ struct radius_server_data;
+@@ -118,6 +119,7 @@ struct hostapd_data {
        struct hostapd_iface *iface;
        struct hostapd_config *iconf;
        struct hostapd_bss_config *conf;
 +      struct hostapd_ubus_bss ubus;
        int interface_added; /* virtual interface added for this BSS */
        unsigned int started:1;
-@@ -256,6 +258,8 @@ struct hostapd_iface {
+       unsigned int disabled:1;
+@@ -323,6 +325,8 @@ struct hostapd_iface {
        struct hostapd_config *conf;
        char phy[16]; /* Name of the PHY (radio) */
  
                HAPD_IFACE_DISABLED,
 --- /dev/null
 +++ b/src/ap/ubus.c
-@@ -0,0 +1,373 @@
+@@ -0,0 +1,536 @@
 +/*
 + * hostapd / ubus support
-+ * Copyright (c) 2013, Felix Fietkau <nbd@openwrt.org>
++ * Copyright (c) 2013, Felix Fietkau <nbd@nbd.name>
 + *
 + * This software may be distributed under the terms of the BSD license.
 + * See README for more details.
 +#include "utils/eloop.h"
 +#include "common/ieee802_11_defs.h"
 +#include "hostapd.h"
++#include "wps_hostapd.h"
 +#include "sta_info.h"
 +#include "ubus.h"
++#include "ap_drv_ops.h"
++#include "beacon.h"
 +
 +static struct ubus_context *ctx;
 +static struct blob_buf b;
 +static int ctx_ref;
 +
++static inline struct hostapd_data *get_hapd_from_object(struct ubus_object *obj)
++{
++      return container_of(obj, struct hostapd_data, ubus.obj);
++}
++
++
 +struct ubus_banned_client {
 +      struct avl_node avl;
 +      u8 addr[ETH_ALEN];
 +      return 0;
 +}
 +
++static int
++hostapd_bss_wps_start(struct ubus_context *ctx, struct ubus_object *obj,
++                      struct ubus_request_data *req, const char *method,
++                      struct blob_attr *msg)
++{
++      int rc;
++      struct hostapd_data *hapd = container_of(obj, struct hostapd_data, ubus.obj);
++
++      rc = hostapd_wps_button_pushed(hapd, NULL);
++
++      if (rc != 0)
++              return UBUS_STATUS_NOT_SUPPORTED;
++
++      return 0;
++}
++
++static int
++hostapd_bss_wps_cancel(struct ubus_context *ctx, struct ubus_object *obj,
++                      struct ubus_request_data *req, const char *method,
++                      struct blob_attr *msg)
++{
++      int rc;
++      struct hostapd_data *hapd = container_of(obj, struct hostapd_data, ubus.obj);
++
++      rc = hostapd_wps_cancel(hapd);
++
++      if (rc != 0)
++              return UBUS_STATUS_NOT_SUPPORTED;
++
++      return 0;
++}
++
++static int
++hostapd_bss_update_beacon(struct ubus_context *ctx, struct ubus_object *obj,
++                      struct ubus_request_data *req, const char *method,
++                      struct blob_attr *msg)
++{
++      int rc;
++      struct hostapd_data *hapd = container_of(obj, struct hostapd_data, ubus.obj);
++
++      rc = ieee802_11_set_beacon(hapd);
++
++      if (rc != 0)
++              return UBUS_STATUS_NOT_SUPPORTED;
++
++      return 0;
++}
++
++enum {
++      CSA_FREQ,
++      CSA_BCN_COUNT,
++      __CSA_MAX
++};
++
++static const struct blobmsg_policy csa_policy[__CSA_MAX] = {
++      /*
++       * for now, frequency and beacon count are enough, add more
++       * parameters on demand
++       */
++      [CSA_FREQ] = { "freq", BLOBMSG_TYPE_INT32 },
++      [CSA_BCN_COUNT] = { "bcn_count", BLOBMSG_TYPE_INT32 },
++};
++
++#ifdef NEED_AP_MLME
++static int
++hostapd_switch_chan(struct ubus_context *ctx, struct ubus_object *obj,
++                  struct ubus_request_data *req, const char *method,
++                  struct blob_attr *msg)
++{
++      struct blob_attr *tb[__CSA_MAX];
++      struct hostapd_data *hapd = get_hapd_from_object(obj);
++      struct csa_settings css;
++
++      blobmsg_parse(csa_policy, __CSA_MAX, tb, blob_data(msg), blob_len(msg));
++
++      if (!tb[CSA_FREQ])
++              return UBUS_STATUS_INVALID_ARGUMENT;
++
++      memset(&css, 0, sizeof(css));
++      css.freq_params.freq = blobmsg_get_u32(tb[CSA_FREQ]);
++      if (tb[CSA_BCN_COUNT])
++              css.cs_count = blobmsg_get_u32(tb[CSA_BCN_COUNT]);
++
++      if (hostapd_switch_channel(hapd, &css) != 0)
++              return UBUS_STATUS_NOT_SUPPORTED;
++      return UBUS_STATUS_OK;
++}
++#endif
++
++enum {
++      VENDOR_ELEMENTS,
++      __VENDOR_ELEMENTS_MAX
++};
++
++static const struct blobmsg_policy ve_policy[__VENDOR_ELEMENTS_MAX] = {
++      /* vendor elements are provided as hex-string */
++      [VENDOR_ELEMENTS] = { "vendor_elements", BLOBMSG_TYPE_STRING },
++};
++
++static int
++hostapd_vendor_elements(struct ubus_context *ctx, struct ubus_object *obj,
++                      struct ubus_request_data *req, const char *method,
++                      struct blob_attr *msg)
++{
++      struct blob_attr *tb[__VENDOR_ELEMENTS_MAX];
++      struct hostapd_data *hapd = get_hapd_from_object(obj);
++      struct hostapd_bss_config *bss = hapd->conf;
++      struct wpabuf *elems;
++      const char *pos;
++      size_t len;
++
++      blobmsg_parse(ve_policy, __VENDOR_ELEMENTS_MAX, tb,
++                    blob_data(msg), blob_len(msg));
++
++      if (!tb[VENDOR_ELEMENTS])
++              return UBUS_STATUS_INVALID_ARGUMENT;
++
++      pos = blobmsg_data(tb[VENDOR_ELEMENTS]);
++      len = os_strlen(pos);
++      if (len & 0x01)
++                      return UBUS_STATUS_INVALID_ARGUMENT;
++
++      len /= 2;
++      if (len == 0) {
++              wpabuf_free(bss->vendor_elements);
++              bss->vendor_elements = NULL;
++              return 0;
++      }
++
++      elems = wpabuf_alloc(len);
++      if (elems == NULL)
++              return 1;
++
++      if (hexstr2bin(pos, wpabuf_put(elems, len), len)) {
++              wpabuf_free(elems);
++              return UBUS_STATUS_INVALID_ARGUMENT;
++      }
++
++      wpabuf_free(bss->vendor_elements);
++      bss->vendor_elements = elems;
++
++      /* update beacons if vendor elements were set successfully */
++      if (ieee802_11_update_beacons(hapd->iface) != 0)
++              return UBUS_STATUS_NOT_SUPPORTED;
++      return UBUS_STATUS_OK;
++}
++
 +static const struct ubus_method bss_methods[] = {
 +      UBUS_METHOD_NOARG("get_clients", hostapd_bss_get_clients),
 +      UBUS_METHOD("del_client", hostapd_bss_del_client, del_policy),
 +      UBUS_METHOD_NOARG("list_bans", hostapd_bss_list_bans),
++      UBUS_METHOD_NOARG("wps_start", hostapd_bss_wps_start),
++      UBUS_METHOD_NOARG("wps_cancel", hostapd_bss_wps_cancel),
++      UBUS_METHOD_NOARG("update_beacon", hostapd_bss_update_beacon),
++#ifdef NEED_AP_MLME
++      UBUS_METHOD("switch_chan", hostapd_switch_chan, csa_policy),
++#endif
++      UBUS_METHOD("set_vendor_elements", hostapd_vendor_elements, ve_policy),
 +};
 +
 +static struct ubus_object_type bss_object_type =
 @@ -0,0 +1,78 @@
 +/*
 + * hostapd / ubus support
-+ * Copyright (c) 2013, Felix Fietkau <nbd@openwrt.org>
++ * Copyright (c) 2013, Felix Fietkau <nbd@nbd.name>
 + *
 + * This software may be distributed under the terms of the BSD license.
 + * See README for more details.
 +#endif
 --- a/src/ap/hostapd.c
 +++ b/src/ap/hostapd.c
-@@ -262,6 +262,7 @@ static void hostapd_free_hapd_data(struc
+@@ -284,6 +284,7 @@ static void hostapd_free_hapd_data(struc
        hapd->started = 0;
  
        wpa_printf(MSG_DEBUG, "%s(%s)", __func__, hapd->conf->iface);
        iapp_deinit(hapd->iapp);
        hapd->iapp = NULL;
        accounting_deinit(hapd);
-@@ -831,6 +832,8 @@ static int hostapd_setup_bss(struct host
+@@ -1140,6 +1141,8 @@ static int hostapd_setup_bss(struct host
        if (hapd->driver && hapd->driver->set_operstate)
                hapd->driver->set_operstate(hapd->drv_priv, 1);
  
        return 0;
  }
  
-@@ -1105,6 +1108,7 @@ int hostapd_setup_interface_complete(str
+@@ -1665,6 +1668,7 @@ static int hostapd_setup_interface_compl
        if (err)
-               goto error;
+               goto fail;
  
 +      hostapd_ubus_add_iface(iface);
        wpa_printf(MSG_DEBUG, "Completing interface initialization");
        if (iface->conf->channel) {
  #ifdef NEED_AP_MLME
-@@ -1213,6 +1217,7 @@ int hostapd_setup_interface_complete(str
+@@ -1845,6 +1849,7 @@ dfs_offload:
  
error:
fail:
        wpa_printf(MSG_ERROR, "Interface initialization failed");
 +      hostapd_ubus_free_iface(iface);
        hostapd_set_state(iface, HAPD_IFACE_DISABLED);
-       if (iface->interfaces && iface->interfaces->terminate_on_error)
-               eloop_terminate();
-@@ -1534,6 +1539,7 @@ void hostapd_interface_deinit_free(struc
+       wpa_msg(hapd->msg_ctx, MSG_INFO, AP_EVENT_DISABLED);
+ #ifdef CONFIG_FST
+@@ -2279,6 +2284,7 @@ void hostapd_interface_deinit_free(struc
                   (unsigned int) iface->conf->num_bss);
        driver = iface->bss[0]->driver;
        drv_priv = iface->bss[0]->drv_priv;
                   __func__, driver, drv_priv);
 --- a/src/ap/ieee802_11.c
 +++ b/src/ap/ieee802_11.c
-@@ -535,7 +535,8 @@ static void handle_auth_sae(struct hosta
+@@ -980,7 +980,8 @@ int auth_sae_init_committed(struct hosta
  
  
  static void handle_auth(struct hostapd_data *hapd,
  {
        u16 auth_alg, auth_transaction, status_code;
        u16 resp = WLAN_STATUS_SUCCESS;
-@@ -550,6 +551,11 @@ static void handle_auth(struct hostapd_d
-       size_t resp_ies_len = 0;
+@@ -996,6 +997,11 @@ static void handle_auth(struct hostapd_d
        char *identity = NULL;
        char *radius_cui = NULL;
+       u16 seq_ctrl;
 +      struct hostapd_ubus_request req = {
 +              .type = HOSTAPD_UBUS_AUTH_REQ,
 +              .mgmt_frame = mgmt,
 +              .frame_info = fi,
 +      };
  
-       if (len < IEEE80211_HDRLEN + sizeof(mgmt->u.auth)) {
-               wpa_printf(MSG_INFO, "handle_auth - too short payload (len=%lu)",
-@@ -633,6 +639,14 @@ static void handle_auth(struct hostapd_d
+       os_memset(&vlan_id, 0, sizeof(vlan_id));
+@@ -1149,6 +1155,14 @@ static void handle_auth(struct hostapd_d
                resp = WLAN_STATUS_UNSPECIFIED_FAILURE;
                goto fail;
        }
        if (res == HOSTAPD_ACL_PENDING) {
                wpa_printf(MSG_DEBUG, "Authentication frame from " MACSTR
                           " waiting for an external authentication",
-@@ -1245,13 +1259,18 @@ static void send_assoc_resp(struct hosta
+@@ -2052,13 +2066,18 @@ static u16 send_assoc_resp(struct hostap
  
  static void handle_assoc(struct hostapd_data *hapd,
                         const struct ieee80211_mgmt *mgmt, size_t len,
 -                       int reassoc)
 +                       int reassoc, struct hostapd_frame_info *fi)
  {
-       u16 capab_info, listen_interval;
-       u16 resp = WLAN_STATUS_SUCCESS;
+       u16 capab_info, listen_interval, seq_ctrl, fc;
+       u16 resp = WLAN_STATUS_SUCCESS, reply_res;
        const u8 *pos;
        int left, i;
        struct sta_info *sta;
  
        if (len < IEEE80211_HDRLEN + (reassoc ? sizeof(mgmt->u.reassoc_req) :
                                      sizeof(mgmt->u.assoc_req))) {
-@@ -1350,6 +1369,13 @@ static void handle_assoc(struct hostapd_
-               goto fail;
+@@ -2178,6 +2197,13 @@ static void handle_assoc(struct hostapd_
        }
+ #endif /* CONFIG_MBO */
  
 +      if (hostapd_ubus_handle_event(hapd, &req)) {
 +              wpa_printf(MSG_DEBUG, "Station " MACSTR " assoc rejected by ubus handler.\n",
 +              goto fail;
 +      }
 +
-       sta->capability = capab_info;
-       sta->listen_interval = listen_interval;
-@@ -1759,7 +1785,7 @@ void ieee802_11_mgmt(struct hostapd_data
+       /*
+        * sta->capability is used in check_assoc_ies() for RRM enabled
+        * capability element.
+@@ -2654,7 +2680,7 @@ int ieee802_11_mgmt(struct hostapd_data
  
  
        if (stype == WLAN_FC_STYPE_PROBE_REQ) {
 -              handle_probe_req(hapd, mgmt, len, fi->ssi_signal);
 +              handle_probe_req(hapd, mgmt, len, fi);
-               return;
+               return 1;
        }
  
-@@ -1774,15 +1800,15 @@ void ieee802_11_mgmt(struct hostapd_data
+@@ -2672,17 +2698,17 @@ int ieee802_11_mgmt(struct hostapd_data
        switch (stype) {
        case WLAN_FC_STYPE_AUTH:
                wpa_printf(MSG_DEBUG, "mgmt::auth");
 -              handle_auth(hapd, mgmt, len);
 +              handle_auth(hapd, mgmt, len, fi);
+               ret = 1;
                break;
        case WLAN_FC_STYPE_ASSOC_REQ:
                wpa_printf(MSG_DEBUG, "mgmt::assoc_req");
 -              handle_assoc(hapd, mgmt, len, 0);
 +              handle_assoc(hapd, mgmt, len, 0, fi);
+               ret = 1;
                break;
        case WLAN_FC_STYPE_REASSOC_REQ:
                wpa_printf(MSG_DEBUG, "mgmt::reassoc_req");
 -              handle_assoc(hapd, mgmt, len, 1);
 +              handle_assoc(hapd, mgmt, len, 1, fi);
+               ret = 1;
                break;
        case WLAN_FC_STYPE_DISASSOC:
-               wpa_printf(MSG_DEBUG, "mgmt::disassoc");
 --- a/src/ap/beacon.c
 +++ b/src/ap/beacon.c
-@@ -398,7 +398,7 @@ static enum ssid_match_result ssid_match
+@@ -675,7 +675,7 @@ sta_track_seen_on(struct hostapd_iface *
  
  void handle_probe_req(struct hostapd_data *hapd,
                      const struct ieee80211_mgmt *mgmt, size_t len,
  {
        u8 *resp;
        struct ieee802_11_elems elems;
-@@ -406,8 +406,14 @@ void handle_probe_req(struct hostapd_dat
-       size_t ie_len;
-       struct sta_info *sta = NULL;
+@@ -684,9 +684,15 @@ void handle_probe_req(struct hostapd_dat
        size_t i, resp_len;
-+      int ssi_signal = fi->ssi_signal;
        int noack;
        enum ssid_match_result res;
++      int ssi_signal = fi->ssi_signal;
+       int ret;
+       u16 csa_offs[2];
+       size_t csa_offs_len;
 +      struct hostapd_ubus_request req = {
 +              .type = HOSTAPD_UBUS_PROBE_REQ,
 +              .mgmt_frame = mgmt,
 +              .frame_info = fi,
 +      };
  
-       ie = mgmt->u.probe_req.variable;
-       if (len < IEEE80211_HDRLEN + sizeof(mgmt->u.probe_req))
-@@ -546,6 +552,12 @@ void handle_probe_req(struct hostapd_dat
+       if (len < IEEE80211_HDRLEN)
+               return;
+@@ -838,6 +844,12 @@ void handle_probe_req(struct hostapd_dat
        }
  #endif /* CONFIG_P2P */
  
  
 --- a/src/ap/beacon.h
 +++ b/src/ap/beacon.h
-@@ -20,7 +20,7 @@ struct ieee80211_mgmt;
+@@ -14,7 +14,7 @@ struct ieee80211_mgmt;
  
  void handle_probe_req(struct hostapd_data *hapd,
                      const struct ieee80211_mgmt *mgmt, size_t len,
 -                    int ssi_signal);
 +                    struct hostapd_frame_info *fi);
- void ieee802_11_set_beacon(struct hostapd_data *hapd);
- void ieee802_11_set_beacons(struct hostapd_iface *iface);
- void ieee802_11_update_beacons(struct hostapd_iface *iface);
+ int ieee802_11_set_beacon(struct hostapd_data *hapd);
+ int ieee802_11_set_beacons(struct hostapd_iface *iface);
+ int ieee802_11_update_beacons(struct hostapd_iface *iface);
+--- a/src/ap/drv_callbacks.c
++++ b/src/ap/drv_callbacks.c
+@@ -52,6 +52,10 @@ int hostapd_notif_assoc(struct hostapd_d
+       u16 reason = WLAN_REASON_UNSPECIFIED;
+       u16 status = WLAN_STATUS_SUCCESS;
+       const u8 *p2p_dev_addr = NULL;
++      struct hostapd_ubus_request req = {
++              .type = HOSTAPD_UBUS_ASSOC_REQ,
++              .addr = addr,
++      };
+       if (addr == NULL) {
+               /*
+@@ -131,6 +135,12 @@ int hostapd_notif_assoc(struct hostapd_d
+               goto fail;
+       }
++      if (hostapd_ubus_handle_event(hapd, &req)) {
++              wpa_printf(MSG_DEBUG, "Station " MACSTR " assoc rejected by ubus handler.\n",
++                         MAC2STR(req.addr));
++              goto fail;
++      }
++
+ #ifdef CONFIG_P2P
+       if (elems.p2p) {
+               wpabuf_free(sta->p2p_ie);