fstools: update to the latest version, adds support for ext4/f2fs overlay via loopbac...
[openwrt/staging/dedeckeh.git] / package / system / fstools / Makefile
index 40adf0af5725b60ecad8e0812178b0305e7053ee..1254510f43ce730087c43d62d1cdb3b71c6d0cd2 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2014 OpenWrt.org
+# Copyright (C) 2014-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,38 +8,53 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=fstools
-PKG_VERSION:=2014-06-02
+PKG_VERSION:=2016-09-08
 
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=git://nbd.name/fstools.git
+PKG_SOURCE_URL=$(LEDE_GIT)/project/fstools.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=d04e58946eff771bf59db90d7a2301b746141ac4
+PKG_SOURCE_VERSION:=fe514c9a20365ba00232c2c981463f43a4a41a7d
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 CMAKE_INSTALL:=1
 
-PKG_LICENSE:=GPLv2
+PKG_LICENSE:=GPL-2.0
 PKG_LICENSE_FILES:=
 
-PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
+PKG_USE_MIPS16:=0
+
+PKG_MAINTAINER:=John Crispin <john@phrozen.org>
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/cmake.mk
 
-TARGET_LDFLAGS += $(if $(CONFIG_USE_EGLIBC),-lrt)
+TARGET_LDFLAGS += $(if $(CONFIG_USE_GLIBC),-lrt)
+CMAKE_OPTIONS += $(if $(CONFIG_FSTOOLS_UBIFS_EXTROOT),-DCMAKE_UBIFS_EXTROOT=y)
 
 define Package/fstools
   SECTION:=base
   CATEGORY:=Base system
-  DEPENDS:=+ubox +USE_EGLIBC:librt
+  DEPENDS:=+ubox +USE_GLIBC:librt +NAND_SUPPORT:ubi-utils
   TITLE:=OpenWrt filesystem tools
+  MENU:=1
+endef
+
+define Package/fstools/config
+       config FSTOOLS_UBIFS_EXTROOT
+               depends on PACKAGE_fstools
+               depends on NAND_SUPPORT
+               bool "Support extroot functionality with UBIFS"
+               default y
+               help
+                       This option makes it possible to use extroot functionality if the root filesystem resides on an UBIFS partition
 endef
 
-define Package/ubi-flash
+define Package/snapshot-tool
   SECTION:=base
   CATEGORY:=Base system
-  TITLE:=OpenWrt ubi flashing tool
+  TITLE:=rootfs snapshoting tool
+  DEPENDS:=+libubox +fstools
 endef
 
 define Package/block-mount
@@ -52,16 +67,16 @@ endef
 define Package/fstools/install
        $(INSTALL_DIR) $(1)/sbin $(1)/lib
 
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/{mount_root,jffs2reset,snapshot_tool} $(1)/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/{mount_root,jffs2reset} $(1)/sbin/
        $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libfstools.so $(1)/lib/
-       $(INSTALL_BIN) ./files/snapshot $(1)/sbin/
-       ln -s /sbin/jffs2reset $(1)/sbin/jffs2mark
+       $(LN) jffs2reset $(1)/sbin/jffs2mark
 endef
 
-define Package/ubi-flash/install
-       $(INSTALL_DIR) $(1)/sbin $(1)/lib
+define Package/snapshot-tool/install
+       $(INSTALL_DIR) $(1)/sbin
 
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/ubi $(1)/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/snapshot_tool $(1)/sbin/
+       $(INSTALL_BIN) ./files/snapshot $(1)/sbin/
 endef
 
 define Package/block-mount/install
@@ -73,11 +88,18 @@ define Package/block-mount/install
 
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/block $(1)/sbin/
        $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libblkid-tiny.so $(1)/lib/
-       ln -s /sbin/block $(1)/usr/sbin/swapon
-       ln -s /sbin/block $(1)/usr/sbin/swapoff
+       $(LN) ../../sbin/block $(1)/usr/sbin/swapon
+       $(LN) ../../sbin/block $(1)/usr/sbin/swapoff
+
+endef
 
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/*.h $(1)/usr/include/
+       $(INSTALL_DIR) $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libubi-utils.a $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,fstools))
-$(eval $(call BuildPackage,ubi-flash))
+$(eval $(call BuildPackage,snapshot-tool))
 $(eval $(call BuildPackage,block-mount))