e2fsprogs: fix glibc compile issue (FS#1749,FS#1796)
[openwrt/staging/dedeckeh.git] / package / utils / e2fsprogs / Makefile
index 13a408718d34ed3d1ecd861afb9a2fa372d12df2..48f812a30ccc5cd90f35134ee6e831db246ee03a 100644 (file)
@@ -132,6 +132,8 @@ $(call Package/e2fsprogs)
 endef
 
 TARGET_CFLAGS += $(FPIC) -ffunction-sections -fdata-sections -flto
+
+TARGET_LDFLAGS += $(if $(CONFIG_USE_GLIBC),-lrt)
 TARGET_LDFLAGS += -flto
 
 CONFIGURE_ARGS += \