kernel: Fix the incorrect i_nlink count after jffs2's RENAME_EXCHANGE operations.
[openwrt/staging/dedeckeh.git] / rules.mk
index d455f0d960e9d8f0c085bea8a7125f379f074880..04fd936660bef4af49de5500cd2d7c3601c1b9f6 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -15,6 +15,11 @@ endif
 include $(TOPDIR)/include/debug.mk
 include $(TOPDIR)/include/verbose.mk
 
+ifneq ($(filter check,$(MAKECMDGOALS)),)
+CHECK:=1
+DUMP:=1
+endif
+
 export TMP_DIR:=$(TOPDIR)/tmp
 
 qstrip=$(strip $(subst ",,$(1)))
@@ -50,6 +55,8 @@ __tr_template = $(__tr_head)$$(1)$(__tr_tail)
 $(eval toupper = $(call __tr_template,$(chars_lower),$(chars_upper)))
 $(eval tolower = $(call __tr_template,$(chars_upper),$(chars_lower)))
 
+version_abbrev = $(if $(if $(CHECK),,$(DUMP)),$(1),$(shell printf '%.8s' $(1)))
+
 _SINGLE=export MAKEFLAGS=$(space);
 CFLAGS:=
 ARCH:=$(subst i486,i386,$(subst i586,i386,$(subst i686,i386,$(call qstrip,$(CONFIG_ARCH)))))
@@ -376,7 +383,7 @@ endef
 # $(1) => Input directory
 define sha256sums
        (cd $(1); find . -maxdepth 1 -type f -not -name 'sha256sums' -printf "%P\n" | sort | \
-               xargs openssl dgst -sha256 | sed -ne 's!^SHA256(\(.*\))= \(.*\)$$!\2 *\1!p' > sha256sums)
+               xargs -r $(STAGING_DIR_HOST)/bin/mkhash -n sha256 | sed -ne 's!^\(.*\) \(.*\)$$!\1 *\2!p' > sha256sums)
 endef
 
 # file extension
@@ -386,6 +393,9 @@ all:
 FORCE: ;
 .PHONY: FORCE
 
+check: FORCE
+       @true
+
 val.%:
        @$(if $(filter undefined,$(origin $*)),\
                echo "$* undefined" >&2, \