some more build system documentation
[openwrt/staging/dedeckeh.git] / rules.mk
index d52539f3f2b80b0d6a5fd1521a31685720570104..a5934684863098ccc70f0a0ac8d8f739443b29d5 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -58,6 +58,10 @@ PATCH:=$(SCRIPT_DIR)/patch-kernel.sh
 SED:=$(STAGING_DIR)/bin/sed -i -e
 CP:=cp -fpR
 
+INSTALL_BIN:=install -m0755
+INSTALL_DIR:=install -d -m0755
+INSTALL_DATA:=install -m0644
+
 ifneq ($(CONFIG_CCACHE),)
   # FIXME: move this variable to a better location
   export CCACHE_DIR=$(STAGING_DIR)/ccache