kernel: update linux 3.7 to 3.7.7
[openwrt/staging/dedeckeh.git] / target / linux / lantiq / Makefile
index fa74e95af8e3e1b0ca48b248c81cfa9bbaca6647..650b90f70259a55169b022c54502a0bf9489960f 100644 (file)
@@ -6,20 +6,19 @@
 #
 include $(TOPDIR)/rules.mk
 
-ARCH:=mips
 BOARD:=lantiq
-BOARDNAME:=Lantiq GPON/XWAY
+BOARDNAME:=Lantiq GPON/XWAY/SVIP
 FEATURES:=squashfs jffs2
-SUBTARGETS:=falcon xway
+SUBTARGETS=xway ase falcon
 
-LINUX_VERSION:=2.6.37.6
+LINUX_VERSION:=3.7.7
 
-CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
-
-include $(INCLUDE_DIR)/target.mk
+CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 
 define Target/Description
        Build firmware images for Lantiq SoC
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
 $(eval $(call BuildTarget))