kernel: update linux 3.7 to 3.7.7
[openwrt/staging/dedeckeh.git] / target / linux / malta / Makefile
index 69fae6aa5b8caeacec010691f7e6b0035873a162..efa17d986fb32df50c905ba68a5fd848d7c37f16 100644 (file)
@@ -1,23 +1,24 @@
 #
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2010-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
 
-ARCH:=mipsel
 BOARD:=malta
 BOARDNAME:=MIPS Malta CoreLV board (qemu)
-FEATURES:=ramdisk
-CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
+CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
+SUBTARGETS:=le be
+INITRAMFS_EXTRA_FILES:=
+MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=2.6.32.8
+LINUX_VERSION:=3.7.7
+
+DEVICE_TYPE:=developerboard
 
 include $(INCLUDE_DIR)/target.mk
 
-define Target/Description
-       Build firmware images for MTI Malta CoreLV boards.
-endef
+DEFAULT_PACKAGES += wpad-mini kmod-mac80211-hwsim kmod-pcnet32
 
 $(eval $(call BuildTarget))