mpc85xx: remove USB support from kernel
[openwrt/staging/dedeckeh.git] / target / linux / mpc85xx / Makefile
index 01cc4c231db027092a7b1e29c6c92f9ebf37871f..02fdc2f53da6030c983062cf5933311d4adc0cba 100644 (file)
@@ -9,22 +9,19 @@ include $(TOPDIR)/rules.mk
 ARCH:=powerpc
 BOARD:=mpc85xx
 BOARDNAME:=Freescale MPC85xx
-CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=8540
-FEATURES:=spe_fpu squashfs
+CPU_TYPE:=8540
+FEATURES:=squashfs ramdisk
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-SUBTARGETS=generic p1020
+SUBTARGETS:=generic p1020 p2020
 
-LINUX_VERSION:=3.10.1
+KERNEL_PATCHVER:=4.14
+
+KERNELNAME:=zImage
 
 include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += \
        kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
-       kmod-leds-gpio kmod-booke-wdt \
-       swconfig kmod-ath9k wpad-mini
-
-define Target/Description
-       Build images for the Freescale MPC85xx based boards.
-endef
+       kmod-leds-gpio swconfig kmod-ath9k wpad-basic kmod-usb2-fsl
 
 $(eval $(call BuildTarget))