octeon: disable ext4 images
[openwrt/staging/dedeckeh.git] / target / linux / octeon / Makefile
index 182ec1e881ced50b19edfc136f519b96b7bb836c..06b6ad00982a638956e0a9dcccab9ef12a445c3d 100644 (file)
@@ -1,25 +1,26 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
 
-ARCH:=mips
+ARCH:=mips64
 BOARD:=octeon
 BOARDNAME:=Cavium Networks Octeon
-FEATURES:=squashfs jffs2 pci usb
-CFLAGS:=-Os -pipe -mtune=octeon -funit-at-a-time
+FEATURES:=squashfs ramdisk pci usb
+CPU_TYPE:=octeon
+MAINTAINER:=John Crispin <john@phrozen.org>
 
-LINUX_VERSION:=2.6.30.10
-
-include $(INCLUDE_DIR)/target.mk
-
-DEFAULT_PACKAGES += wpad-mini
+KERNEL_PATCHVER:=4.4
 
 define Target/Description
        Build firmware images for Cavium Networks Octeon-based boards.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += mkf2fs e2fsprogs
+
 $(eval $(call BuildTarget))