kernel: makefiles: make use of new var KERNEL_PATCHVER
[openwrt/staging/dedeckeh.git] / target / linux / uml / Makefile
index 5f3181fce21166a63b9e3621347e7490a90f60af..eb4fed11e9d28c289bcb50041c772a4712af43a2 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -20,13 +20,15 @@ ARCH:=$(shell uname -m | sed \
 )
 BOARD:=uml
 BOARDNAME:=User Mode Linux
-FEATURES:=ext2
-LINUX_CONFIG:=$(CURDIR)/config/$(ARCH)
+FEATURES:=ext4 audio
+MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=2.6.30.10
+KERNEL_PATCHVER:=3.14
 
 include $(INCLUDE_DIR)/target.mk
 
+LINUX_TARGET_CONFIG:=$(CURDIR)/config/$(ARCH)
+
 DEFAULT_PACKAGES += wpad-mini kmod-mac80211-hwsim
 
 endif