binutils: enable plugin support
[openwrt/staging/dedeckeh.git] / toolchain / binutils / Makefile
index b88fbd8b2ca96c04a9f55be085026a4dedaa3fa3..8e661b98eb75bdb5ad38510e3586f2d77f5d9685 100644 (file)
@@ -41,6 +41,7 @@ BINUTILS_CONFIGURE:= \
                --host=$(GNU_HOST_NAME) \
                --target=$(REAL_GNU_TARGET_NAME) \
                --with-sysroot=$(TOOLCHAIN_DIR) \
+               --enable-plugins \
                --disable-multilib \
                --disable-werror \
                --disable-nls \
@@ -65,6 +66,7 @@ define Host/Prepare
        $(call Host/Prepare/Default)
        ln -snf $(notdir $(HOST_BUILD_DIR)) $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)
        $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(HOST_BUILD_DIR)/
+       $(SED) 's, " Linaro.*,,' $(HOST_BUILD_DIR)/bfd/version.h
 endef
 
 define Host/Configure