add gcc-4.5.0 preliminary support
[openwrt/staging/dedeckeh.git] / toolchain / gcc / Makefile
index 0970b2f9859127e5917db97fb00b25b03e66303f..ed9de15b3c42a7e25bc91652cf52013a683c163b 100644 (file)
@@ -2,7 +2,7 @@
 # Copyright (C) 2002-2003 Erik Andersen <andersen@uclibc.org>
 # Copyright (C) 2004 Manuel Novoa III <mjn3@uclibc.org>
 # Copyright (C) 2005-2006 Felix Fietkau <nbd@openwrt.org>
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -60,6 +60,12 @@ else
   ifeq ($(PKG_VERSION),4.4.2)
     PKG_MD5SUM:=70f5ac588a79e3c9901d5b34f58d896d
   endif
+  ifeq ($(PKG_VERSION),4.4.3)
+    PKG_MD5SUM:=fe1ca818fc6d2caeffc9051fe67ff103
+  endif
+  ifeq ($(PKG_VERSION),4.5.0)
+  PKG_MD5SUM:=ff27b7c4a5d5060c8a8543a44abca31f
+  endif
 endif
 
 PATCH_DIR=./patches/$(GCC_VERSION)
@@ -90,11 +96,12 @@ GCC_CONFIGURE:= \
                --disable-libmudflap \
                --disable-multilib \
                --disable-nls \
+               $(if $(CONFIG_GCC_USE_GRAPHITE),--with-host-libstdcxx=-lstdc++) \
                $(SOFT_FLOAT_CONFIG_OPTION) \
                $(call qstrip,$(CONFIG_EXTRA_GCC_CONFIG_OPTIONS)) \
                $(if $(CONFIG_mips64)$(CONFIG_mips64el),--with-arch=mips64 --with-abi=64) \
                $(if $(CONFIG_GCC_VERSION_LLVM),--enable-llvm=$(BUILD_DIR_BASE)/host/llvm) \
-               $(if $(CONFIG_GCC_VERSION_4_3_3_CS),--enable-poison-system-directories)
+               $(if $(CONFIG_GCC_VERSION_4_3_3_CS)$(CONFIG_GCC_VERSION_4_4_1_CS)$(CONFIG_GCC_VERSION_4_4_3_CS),--enable-poison-system-directories)
 
 ifneq ($(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4),)
   GCC_BUILD_TARGET_LIBGCC:=y
@@ -104,6 +111,15 @@ ifneq ($(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4),)
                --disable-decimal-float
 endif
 
+ifneq ($(CONFIG_GCC_VERSION_4_5),)
+  GCC_BUILD_TARGET_LIBGCC:=y
+  GCC_CONFIGURE+= \
+                --with-gmp=$(TOPDIR)/staging_dir/host \
+                --with-mpc=$(TOPDIR)/staging_dir/host \
+                --with-mpfr=$(TOPDIR)/staging_dir/host \
+                --disable-decimal-float
+endif
+
 ifneq ($(CONFIG_SSP_SUPPORT),)
   GCC_CONFIGURE+= \
                --enable-libssp
@@ -148,9 +164,20 @@ GCC_CONFIGURE_STAGE2:= \
                --enable-languages=$(TARGET_LANGUAGES) \
                --enable-shared \
                --enable-threads \
-               --disable-tls \
                --with-slibdir=$(TOOLCHAIN_DIR)/lib \
 
+ifneq ($(CONFIG_TLS_SUPPORT),)
+  GCC_CONFIGURE_STAGE2+= \
+               --enable-tls
+else
+  GCC_CONFIGURE_STAGE2+= \
+               --disable-tls
+endif
+
+ifdef CONFIG_powerpc
+  TARGET_CFLAGS := $(patsubst -Os,-O2,$(TARGET_CFLAGS))
+endif
+
 GCC_MAKE:= \
        export SHELL="$(BASH)"; \
        $(MAKE) \
@@ -238,7 +265,7 @@ define SetupExtraArch
 endef
 
 define Stage2/Install
-       $(GCC_MAKE) -C $(HOST_BUILD_DIR2) install
+       $(_SINGLE)$(GCC_MAKE) -C $(HOST_BUILD_DIR2) install
        # Set up the symlinks to enable lying about target name.
        set -e; \
        (cd $(TOOLCHAIN_DIR)/usr; \
@@ -253,13 +280,17 @@ define Stage2/Install
 endef
 
 
+BUGURL=https://dev.openwrt.org/
+
 define Host/Prepare
        $(call Host/SetToolchainInfo)
        $(call Host/Prepare/Default)
        ln -snf $(GCC_DIR) $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)
        $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(HOST_BUILD_DIR)/
+       $(SED) 's,^MULTILIB_OSDIRNAMES,# MULTILIB_OSDIRNAMES,' $(HOST_BUILD_DIR)/gcc/config/*/t-*
        $(SED) 's,\(version_string.. = "[0-9\.]*\).*\(";\),\1 (OpenWrt-2.0)\2,' $(HOST_BUILD_DIR)/gcc/version.c
-       $(SED) 's,\(bug_report_url.. = "\).*\(";\),\1<URL:https://dev.openwrt.org/>\2,' $(HOST_BUILD_DIR)/gcc/version.c
+       $(SED) 's,\(bug_report_url.. = "\).*\(";\),\1<URL:$(BUGURL)>\2,' $(HOST_BUILD_DIR)/gcc/version.c
+       $(SED) 's,http://gcc.gnu.org/bugs.html,$(BUGURL),' $(HOST_BUILD_DIR)/gcc/configure
        #(cd $(HOST_BUILD_DIR)/libstdc++-v3; autoconf;);
        $(SED) 's,gcc_no_link=yes,gcc_no_link=no,' $(HOST_BUILD_DIR)/libstdc++-v3/configure
        $(call Stage0/Configure)