add gcc-4.5.0 preliminary support
[openwrt/staging/dedeckeh.git] / tools / Makefile
index 8fc2da3d96a4df5ce0de33a3588036cd6074ac1c..cad5011c306a6da8ae37b6ab7fbb76601c34ca8e 100644 (file)
@@ -11,8 +11,12 @@ curdir:=tools
 # subdirectories to descend into
 tools-y :=
 ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
+ifeq ($(CONFIG_GCC_VERSION_4_5),y)
+tools-$(CONFIG_GCC_VERSION_4_5) += gmp mpfr mpc
+else
 tools-$(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4) += gmp mpfr
 endif
+endif
 tools-y += m4 autoconf automake bison pkg-config sed mklibs
 tools-y += sstrip ipkg-utils genext2fs libuuid mtd-utils mkimage
 tools-y += firmware-utils patch-cmdline quilt yaffs2
@@ -40,6 +44,7 @@ $(curdir)/quilt/compile := $(curdir)/sed/install
 $(curdir)/dtc/compile := $(curdir)/bison/install
 $(curdir)/autoconf/compile := $(curdir)/m4/install
 $(curdir)/automake/compile := $(curdir)/m4/install $(curdir)/autoconf/install
+$(curdir)/mpc/compile := $(curdir)/gmp/install
 $(curdir)/mpfr/compile := $(curdir)/gmp/install
 $(curdir)/mtd-utils/compile := $(curdir)/libuuid/install