kernel: add missing AddDepends calls for kmod-usb-serial-qualcomm and kmod-ata-sis
authorJo-Philipp Wich <jow@openwrt.org>
Mon, 19 Mar 2012 20:28:49 +0000 (20:28 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Mon, 19 Mar 2012 20:28:49 +0000 (20:28 +0000)
SVN-Revision: 31029

package/kernel/modules/block.mk
package/kernel/modules/usb.mk

index 357f5fd2eba5502dc1d4be0cc8ca3f06b6c39bf2..88dcf1cccd075c596276a7a0faa68eb67c0e6087 100644 (file)
@@ -171,6 +171,7 @@ define KernelPackage/ata-sis
   KCONFIG:=CONFIG_SATA_SIS
   FILES:=$(LINUX_DIR)/drivers/ata/sata_sis.ko
   AUTOLOAD:=$(call AutoLoad,41,sata_sis,1)
+  $(call AddDepends/ata)
 endef
 
 define KernelPackage/ata-sis/description
index fedff208505e0d4eb4608c9862e9bb636c89f1cb..62e79bababe9c4739aee0d433512cd824f12b4e6 100644 (file)
@@ -611,6 +611,7 @@ define KernelPackage/usb-serial-qualcomm
   KCONFIG:=CONFIG_USB_SERIAL_QUALCOMM
   FILES:=$(LINUX_DIR)/drivers/usb/serial/qcserial.ko
   AUTOLOAD:=$(call AutoLoad,65,qcserial)
+  $(call AddDepends/usb-serial)
 endef
 
 define KernelPackage/usb-serial-qualcomm/description