Add support for TL-WA801ND v4
authorRomain MARIADASSOU <roms2000@free.fr>
Sun, 1 Jul 2018 22:55:47 +0000 (00:55 +0200)
committerMatthias Schiffer <mschiffer@universe-factory.net>
Fri, 7 Dec 2018 20:46:45 +0000 (21:46 +0100)
This add support for TP-Link TL-WA801ND v4 (same as TL-WA801ND v3) :

Specification:

- System-On-Chip: Qualcomm Atheros QCA9533
- CPU/Speed: 650 MHz
- Flash-Chip: Winbond W25Q32BVSIG
- Flash size: 4096 KiB
- RAM: 32 MiB
- Wireless No1: SoC-integrated: QCA9533 2.4GHz 802.11bgn

Flash instructions:

1) To flash the image, rename the file
   openwrt-ar71xx-generic-tl-wa801nd-v4-squashfs-factory.bin
   to firmware.bin
2) Connect your device to the LAN port, then upload the firmware
   through web interface. It will try to download the image and
   flash it.

It can take up to 2-3 minutes to finish. When it reaches 100%, the
router will reboot itself.

Signed-off-by: Romain MARIADASSOU <roms2000@free.fr>
target/linux/ar71xx/files/arch/mips/ath79/mach-tl-wa801nd-v3.c
target/linux/ar71xx/image/tiny-tp-link.mk

index 054c14ee73faf629e1faf1efb19e804734602981..1637382192f34a3121d34138dcc73b087e942e43 100644 (file)
@@ -1,5 +1,6 @@
 /*
  *  TP-LINK TL-WA801ND v3 adapted from TP-LINK TL-WR841N/ND v9
+ *  TP-LINK TL-WA801ND v4
  *
  *  Copyright (C) 2014 Matthias Schiffer <mschiffer@universe-factory.net>
  *  Copyright (C) 2016 Tiziano Bacocco <tizbac2@gmail.com>
index 9d3059d127d62ae06879eac55e562f85b968743e..5b0ab3e970753ffc2adf050f42e29e5598a9c4f2 100644 (file)
@@ -203,6 +203,13 @@ define Device/tl-wa801nd-v3
 endef
 TARGET_DEVICES += tl-wa801nd-v3
 
+define Device/tl-wa801nd-v4
+  $(Device/tl-wa801nd-v3)
+  DEVICE_TITLE := TP-LINK TL-WA801N/ND v4
+  TPLINK_HWID := 0x08010004
+endef
+TARGET_DEVICES += tl-wa801nd-v4
+
 define Device/tl-wa830re-v1
   $(Device/tplink-4m)
   DEVICE_TITLE := TP-LINK TL-WA830RE v1