create a package index after build
authorFelix Fietkau <nbd@openwrt.org>
Mon, 7 Mar 2005 15:11:58 +0000 (15:11 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 7 Mar 2005 15:11:58 +0000 (15:11 +0000)
SVN-Revision: 337

openwrt/Makefile

index ed4ea1529fa71424acee631d34dcf3de61ea114d..1a218df586cca268a7b1c5ea9d558ed6dbbedccf 100644 (file)
@@ -69,16 +69,13 @@ package_install: toolchain
 # In this section, we need .config
 include .config.cmd
 
-world: $(DL_DIR) $(BUILD_DIR) target_prepare $(TARGET_DIR) toolchain_install package_install target_install
+world: $(DL_DIR) $(BUILD_DIR) target_prepare $(TARGET_DIR) toolchain_install package_install target_install package_index
 
 .PHONY: all world clean dirclean distclean image_clean target_clean source target_prepare target_install toolchain_install package_install
 
-#############################################################
-#
-# staging and target directories do NOT list these as
-# dependancies anywhere else
-#
-#############################################################
+package_index:
+       $(STAGING_DIR)/usr/bin/ipkg-make-index $(PACKAGE_DIR) > $(PACKAGE_DIR)/Packages
+
 target_prepare:
        $(MAKE) -C target prepare