kernel: update kernel 4.4 to version 4.4.50
authorJo-Philipp Wich <jo@mein.io>
Mon, 20 Feb 2017 13:45:59 +0000 (14:45 +0100)
committerJo-Philipp Wich <jo@mein.io>
Mon, 20 Feb 2017 15:02:54 +0000 (16:02 +0100)
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
14 files changed:
include/kernel-version.mk
target/linux/ar71xx/patches-4.4/910-unaligned_access_hacks.patch
target/linux/arc770/patches-4.4/001-ARC-arcompact-brown-paper-bag-bug-in-unaligned-access-delay-slot-fixup.patch [deleted file]
target/linux/brcm63xx/patches-4.4/413-BCM63XX-allow-providing-fixup-data-in-board-data.patch
target/linux/brcm63xx/patches-4.4/418-MIPS-BCM63XX-pass-caldata-info-to-flash.patch
target/linux/brcm63xx/patches-4.4/420-BCM63XX-add-endian-check-for-ath9k.patch
target/linux/brcm63xx/patches-4.4/421-BCM63XX-add-led-pin-for-ath9k.patch
target/linux/brcm63xx/patches-4.4/422-BCM63XX-add-a-fixup-for-rt2x00-devices.patch
target/linux/generic/patches-4.4/072-net-add-devm-version-of-alloc_etherdev_mqs-function.patch
target/linux/generic/patches-4.4/630-packet_socket_type.patch
target/linux/generic/patches-4.4/666-Add-support-for-MAP-E-FMRs-mesh-mode.patch
target/linux/generic/patches-4.4/680-NET-skip-GRO-for-foreign-MAC-addresses.patch
target/linux/generic/patches-4.4/721-phy_packets.patch
target/linux/layerscape/patches-4.4/7226-dpaa_eth-fix-adjust_link-for-10G-2.5G.patch

index ace1d9cce87f3191f9c3bed6d4ac57cd5b6a9786..21418b85bb48a076ab4b4ad9a6bdfcfa34e1eb02 100644 (file)
@@ -3,10 +3,10 @@
 LINUX_RELEASE?=1
 
 LINUX_VERSION-3.18 = .43
 LINUX_RELEASE?=1
 
 LINUX_VERSION-3.18 = .43
-LINUX_VERSION-4.4 = .47
+LINUX_VERSION-4.4 = .50
 
 LINUX_KERNEL_HASH-3.18.43 = 1236e8123a6ce537d5029232560966feed054ae31776fe8481dd7d18cdd5492c
 
 LINUX_KERNEL_HASH-3.18.43 = 1236e8123a6ce537d5029232560966feed054ae31776fe8481dd7d18cdd5492c
-LINUX_KERNEL_HASH-4.4.47 = ce0ac0016f37ba3e9bc8ad3765933b61c4072fcfe4c44804fc7b308cd7f94de7
+LINUX_KERNEL_HASH-4.4.50 = e4944ca5bb0bdf63a7e97dc7fbdd38bcc820d8b3b57c4a3a7b3bf9c8a48216b7
 
 ifdef KERNEL_PATCHVER
   LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
 
 ifdef KERNEL_PATCHVER
   LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
index 2c014429f20c20f271a61f9ee902b17816a3b011..1e68cf72f56eabcba703b027675e53b9776c8d89 100644 (file)
                case IPV6_2292HOPOPTS:
 --- a/net/ipv6/ip6_gre.c
 +++ b/net/ipv6/ip6_gre.c
                case IPV6_2292HOPOPTS:
 --- a/net/ipv6/ip6_gre.c
 +++ b/net/ipv6/ip6_gre.c
-@@ -394,7 +394,7 @@ static void ip6gre_err(struct sk_buff *s
+@@ -395,7 +395,7 @@ static void ip6gre_err(struct sk_buff *s
+               return;
+       ipv6h = (const struct ipv6hdr *)skb->data;
+       greh = (const struct gre_base_hdr *)(skb->data + offset);
+-      key = key_off ? *(__be32 *)(skb->data + key_off) : 0;
++      key = key_off ? net_hdr_word((__be32 *)(skb->data + key_off)) : 0;
  
        t = ip6gre_tunnel_lookup(skb->dev, &ipv6h->daddr, &ipv6h->saddr,
  
        t = ip6gre_tunnel_lookup(skb->dev, &ipv6h->daddr, &ipv6h->saddr,
-                               flags & GRE_KEY ?
--                              *(((__be32 *)p) + (grehlen / 4) - 1) : 0,
-+                              net_hdr_word(((__be32 *)p) + (grehlen / 4) - 1) : 0,
-                               p[1]);
-       if (!t)
-               return;
-@@ -476,11 +476,11 @@ static int ip6gre_rcv(struct sk_buff *sk
+                                key, greh->protocol);
+@@ -479,11 +479,11 @@ static int ip6gre_rcv(struct sk_buff *sk
                        offset += 4;
                }
                if (flags&GRE_KEY) {
                        offset += 4;
                }
                if (flags&GRE_KEY) {
                        offset += 4;
                }
        }
                        offset += 4;
                }
        }
-@@ -742,7 +742,7 @@ static netdev_tx_t ip6gre_xmit2(struct s
+@@ -745,7 +745,7 @@ static netdev_tx_t ip6gre_xmit2(struct s
  
                if (tunnel->parms.o_flags&GRE_SEQ) {
                        ++tunnel->o_seqno;
  
                if (tunnel->parms.o_flags&GRE_SEQ) {
                        ++tunnel->o_seqno;
                        ptr--;
                }
                if (tunnel->parms.o_flags&GRE_KEY) {
                        ptr--;
                }
                if (tunnel->parms.o_flags&GRE_KEY) {
-@@ -838,7 +838,7 @@ static inline int ip6gre_xmit_ipv6(struc
+@@ -841,7 +841,7 @@ static inline int ip6gre_xmit_ipv6(struc
  
        dsfield = ipv6_get_dsfield(ipv6h);
        if (t->parms.flags & IP6_TNL_F_USE_ORIG_TCLASS)
  
        dsfield = ipv6_get_dsfield(ipv6h);
        if (t->parms.flags & IP6_TNL_F_USE_ORIG_TCLASS)
        if (t->parms.flags & IP6_TNL_F_USE_ORIG_FWMARK)
 --- a/net/ipv6/ip6_tunnel.c
 +++ b/net/ipv6/ip6_tunnel.c
        if (t->parms.flags & IP6_TNL_F_USE_ORIG_FWMARK)
 --- a/net/ipv6/ip6_tunnel.c
 +++ b/net/ipv6/ip6_tunnel.c
-@@ -1397,7 +1397,7 @@ ip6ip6_tnl_xmit(struct sk_buff *skb, str
+@@ -1407,7 +1407,7 @@ ip6ip6_tnl_xmit(struct sk_buff *skb, str
  
        dsfield = ipv6_get_dsfield(ipv6h);
        if (t->parms.flags & IP6_TNL_F_USE_ORIG_TCLASS)
  
        dsfield = ipv6_get_dsfield(ipv6h);
        if (t->parms.flags & IP6_TNL_F_USE_ORIG_TCLASS)
diff --git a/target/linux/arc770/patches-4.4/001-ARC-arcompact-brown-paper-bag-bug-in-unaligned-access-delay-slot-fixup.patch b/target/linux/arc770/patches-4.4/001-ARC-arcompact-brown-paper-bag-bug-in-unaligned-access-delay-slot-fixup.patch
deleted file mode 100644 (file)
index 8f502d9..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
-From patchwork Tue Feb  7 17:44:58 2017
-Content-Type: text/plain; charset="utf-8"
-MIME-Version: 1.0
-Content-Transfer-Encoding: 7bit
-Subject: ARC: [arcompact] brown paper bag bug in unaligned access delay slot
- fixup
-From: Vineet Gupta <Vineet.Gupta1@synopsys.com>
-X-Patchwork-Id: 725238
-Message-Id: <1486489498-9221-1-git-send-email-vgupta@synopsys.com>
-To: Linus Torvalds <torvalds@linux-foundation.org>
-Cc: Vineet Gupta <Vineet.Gupta1@synopsys.com>,
- linux-snps-arc@lists.infradead.org, Jo-Philipp Wich <jo@mein.io>,
- linux-kernel@vger.kernel.org, stable@vger.kernel.org
-Date: Tue, 7 Feb 2017 09:44:58 -0800
-
-Reported-by: Jo-Philipp Wich <jo@mein.io>
-Fixes: 9aed02feae57bf7 ("ARC: [arcompact] handle unaligned access delay slot")
-Cc: linux-kernel@vger.kernel.org
-Cc: linux-snps-arc@lists.infradead.org
-Cc: stable@vger.kernel.org
-Signed-off-by: Vineet Gupta <vgupta@synopsys.com>
----
- arch/arc/kernel/unaligned.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/arch/arc/kernel/unaligned.c b/arch/arc/kernel/unaligned.c
-index 91ebe382147f..5f69c3bd59bb 100644
---- a/arch/arc/kernel/unaligned.c
-+++ b/arch/arc/kernel/unaligned.c
-@@ -243,7 +243,7 @@ int misaligned_fixup(unsigned long address, struct pt_regs *regs,
-       /* clear any remanants of delay slot */
-       if (delay_mode(regs)) {
--              regs->ret = regs->bta ~1U;
-+              regs->ret = regs->bta & ~1U;
-               regs->status32 &= ~STATUS_DE_MASK;
-       } else {
-               regs->ret += state.instr_len;
index ab44dc439bca88189ddc12c1d404c4871e16a655..90e71f7c30c5ecf5ee113e97335535e7a5446427 100644 (file)
@@ -26,7 +26,7 @@ Subject: [PATCH 58/72] BCM63XX: allow providing fixup data in board data
  
  #if CONFIG_OF
        if (of_have_populated_dt()) {
  
  #if CONFIG_OF
        if (of_have_populated_dt()) {
-@@ -265,6 +267,10 @@ int __init board_register_devices(void)
+@@ -262,6 +264,10 @@ int __init board_register_devices(void)
                                        board.ephy_reset_gpio_flags);
        }
  
                                        board.ephy_reset_gpio_flags);
        }
  
index b3931982e011b6bc5ba9279b6cbebc626001c261..f1e3788f7a27e8d8654329253ddbde5d95769943 100644 (file)
@@ -11,7 +11,7 @@ Subject: [PATCH 69/80] MIPS: BCM63XX: pass caldata info to flash
 
 --- a/arch/mips/bcm63xx/boards/board_common.c
 +++ b/arch/mips/bcm63xx/boards/board_common.c
 
 --- a/arch/mips/bcm63xx/boards/board_common.c
 +++ b/arch/mips/bcm63xx/boards/board_common.c
-@@ -255,7 +255,7 @@ int __init board_register_devices(void)
+@@ -252,7 +252,7 @@ int __init board_register_devices(void)
        if (board.num_spis)
                spi_register_board_info(board.spis, board.num_spis);
  
        if (board.num_spis)
                spi_register_board_info(board.spis, board.num_spis);
  
index fd5cbfb51f39a2bb306c00d8b4bd46277eb9d50a..1510e6a15c1ab216e5d0a0d06adfe084820c0938 100644 (file)
@@ -39,7 +39,7 @@
                return;
 --- a/arch/mips/bcm63xx/boards/board_common.c
 +++ b/arch/mips/bcm63xx/boards/board_common.c
                return;
 --- a/arch/mips/bcm63xx/boards/board_common.c
 +++ b/arch/mips/bcm63xx/boards/board_common.c
-@@ -269,7 +269,8 @@ int __init board_register_devices(void)
+@@ -266,7 +266,8 @@ int __init board_register_devices(void)
  
        /* register any fixups */
        for (i = 0; i < board.has_caldata; i++)
  
        /* register any fixups */
        for (i = 0; i < board.has_caldata; i++)
index c18d8db048130325b2d07cc4c21de4b106ddb15e..142d161e16df2e7eacf693d37f6ef2218369249f 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_common.c
 +++ b/arch/mips/bcm63xx/boards/board_common.c
 --- a/arch/mips/bcm63xx/boards/board_common.c
 +++ b/arch/mips/bcm63xx/boards/board_common.c
-@@ -270,7 +270,7 @@ int __init board_register_devices(void)
+@@ -267,7 +267,7 @@ int __init board_register_devices(void)
        /* register any fixups */
        for (i = 0; i < board.has_caldata; i++)
                pci_enable_ath9k_fixup(board.caldata[i].slot, board.caldata[i].caldata_offset,
        /* register any fixups */
        for (i = 0; i < board.has_caldata; i++)
                pci_enable_ath9k_fixup(board.caldata[i].slot, board.caldata[i].caldata_offset,
index cdbecfd0eb1bbc90c10f2fd231c20d14ac65516b..a764504dbb42dabeff39bf100169f12e5175df29 100644 (file)
@@ -36,7 +36,7 @@ Subject: [PATCH 72/72] 446-BCM63XX-add-a-fixup-for-rt2x00-devices
  
  #include "board_common.h"
  
  
  #include "board_common.h"
  
-@@ -268,9 +269,19 @@ int __init board_register_devices(void)
+@@ -265,9 +266,19 @@ int __init board_register_devices(void)
        }
  
        /* register any fixups */
        }
  
        /* register any fixups */
index 1d44d487c74364b1a55269fcd2384427207350e2..be03cca9ee754985a717b3c44c49a10ab6460f14 100644 (file)
@@ -33,7 +33,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  int eth_gro_complete(struct sk_buff *skb, int nhoff);
 --- a/net/ethernet/eth.c
 +++ b/net/ethernet/eth.c
  int eth_gro_complete(struct sk_buff *skb, int nhoff);
 --- a/net/ethernet/eth.c
 +++ b/net/ethernet/eth.c
-@@ -387,6 +387,34 @@ struct net_device *alloc_etherdev_mqs(in
+@@ -388,6 +388,34 @@ struct net_device *alloc_etherdev_mqs(in
  }
  EXPORT_SYMBOL(alloc_etherdev_mqs);
  
  }
  EXPORT_SYMBOL(alloc_etherdev_mqs);
  
index eb79b2dd37569bdee0c589439dfb1319f3602358..71ff0eb6cf929a6a818f0aebbce40052419992d7 100644 (file)
@@ -83,7 +83,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        if (!net_eq(dev_net(dev), sock_net(sk)))
                goto drop;
  
        if (!net_eq(dev_net(dev), sock_net(sk)))
                goto drop;
  
-@@ -3091,6 +3093,7 @@ static int packet_create(struct net *net
+@@ -3092,6 +3094,7 @@ static int packet_create(struct net *net
        mutex_init(&po->pg_vec_lock);
        po->rollover = NULL;
        po->prot_hook.func = packet_rcv;
        mutex_init(&po->pg_vec_lock);
        po->rollover = NULL;
        po->prot_hook.func = packet_rcv;
@@ -91,7 +91,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
        if (sock->type == SOCK_PACKET)
                po->prot_hook.func = packet_rcv_spkt;
  
        if (sock->type == SOCK_PACKET)
                po->prot_hook.func = packet_rcv_spkt;
-@@ -3713,6 +3716,16 @@ packet_setsockopt(struct socket *sock, i
+@@ -3714,6 +3717,16 @@ packet_setsockopt(struct socket *sock, i
                po->xmit = val ? packet_direct_xmit : dev_queue_xmit;
                return 0;
        }
                po->xmit = val ? packet_direct_xmit : dev_queue_xmit;
                return 0;
        }
@@ -108,7 +108,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        default:
                return -ENOPROTOOPT;
        }
        default:
                return -ENOPROTOOPT;
        }
-@@ -3765,6 +3778,13 @@ static int packet_getsockopt(struct sock
+@@ -3766,6 +3779,13 @@ static int packet_getsockopt(struct sock
        case PACKET_VNET_HDR:
                val = po->has_vnet_hdr;
                break;
        case PACKET_VNET_HDR:
                val = po->has_vnet_hdr;
                break;
index c86f4c71692b105a843cba7d124a2251e259673d..da8e8a64f51ace50140ae677f95a49e5ed8b7550 100644 (file)
@@ -160,7 +160,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
        if (dev == ip6n->fb_tnl_dev)
                RCU_INIT_POINTER(ip6n->tnls_wc[0], NULL);
        else
        if (dev == ip6n->fb_tnl_dev)
                RCU_INIT_POINTER(ip6n->tnls_wc[0], NULL);
        else
-@@ -846,6 +861,108 @@ int ip6_tnl_rcv_ctl(struct ip6_tnl *t,
+@@ -856,6 +871,108 @@ int ip6_tnl_rcv_ctl(struct ip6_tnl *t,
  }
  EXPORT_SYMBOL_GPL(ip6_tnl_rcv_ctl);
  
  }
  EXPORT_SYMBOL_GPL(ip6_tnl_rcv_ctl);
  
@@ -269,7 +269,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
  /**
   * ip6_tnl_rcv - decapsulate IPv6 packet and retransmit it locally
   *   @skb: received socket buffer
  /**
   * ip6_tnl_rcv - decapsulate IPv6 packet and retransmit it locally
   *   @skb: received socket buffer
-@@ -891,6 +1008,26 @@ static int ip6_tnl_rcv(struct sk_buff *s
+@@ -901,6 +1018,26 @@ static int ip6_tnl_rcv(struct sk_buff *s
                skb_reset_network_header(skb);
                skb->protocol = htons(protocol);
                memset(skb->cb, 0, sizeof(struct inet6_skb_parm));
                skb_reset_network_header(skb);
                skb->protocol = htons(protocol);
                memset(skb->cb, 0, sizeof(struct inet6_skb_parm));
@@ -296,7 +296,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
  
                __skb_tunnel_rx(skb, t->dev, t->net);
  
  
                __skb_tunnel_rx(skb, t->dev, t->net);
  
-@@ -1235,6 +1372,7 @@ ip6ip6_tnl_xmit(struct sk_buff *skb, str
+@@ -1245,6 +1382,7 @@ ip6ip6_tnl_xmit(struct sk_buff *skb, str
        __u32 mtu;
        u8 tproto;
        int err;
        __u32 mtu;
        u8 tproto;
        int err;
@@ -304,7 +304,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
  
        tproto = ACCESS_ONCE(t->parms.proto);
        if ((tproto != IPPROTO_IPV6 && tproto != 0) ||
  
        tproto = ACCESS_ONCE(t->parms.proto);
        if ((tproto != IPPROTO_IPV6 && tproto != 0) ||
-@@ -1265,6 +1403,18 @@ ip6ip6_tnl_xmit(struct sk_buff *skb, str
+@@ -1275,6 +1413,18 @@ ip6ip6_tnl_xmit(struct sk_buff *skb, str
        if (t->parms.flags & IP6_TNL_F_USE_ORIG_FWMARK)
                fl6.flowi6_mark = skb->mark;
  
        if (t->parms.flags & IP6_TNL_F_USE_ORIG_FWMARK)
                fl6.flowi6_mark = skb->mark;
  
@@ -323,7 +323,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
        err = ip6_tnl_xmit2(skb, dev, dsfield, &fl6, encap_limit, &mtu);
        if (err != 0) {
                if (err == -EMSGSIZE)
        err = ip6_tnl_xmit2(skb, dev, dsfield, &fl6, encap_limit, &mtu);
        if (err != 0) {
                if (err == -EMSGSIZE)
-@@ -1379,6 +1529,14 @@ ip6_tnl_change(struct ip6_tnl *t, const
+@@ -1389,6 +1539,14 @@ ip6_tnl_change(struct ip6_tnl *t, const
        t->parms.flowinfo = p->flowinfo;
        t->parms.link = p->link;
        t->parms.proto = p->proto;
        t->parms.flowinfo = p->flowinfo;
        t->parms.link = p->link;
        t->parms.proto = p->proto;
@@ -338,7 +338,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
        ip6_tnl_dst_reset(t);
        ip6_tnl_link_config(t);
        return 0;
        ip6_tnl_dst_reset(t);
        ip6_tnl_link_config(t);
        return 0;
-@@ -1417,6 +1575,7 @@ ip6_tnl_parm_from_user(struct __ip6_tnl_
+@@ -1427,6 +1585,7 @@ ip6_tnl_parm_from_user(struct __ip6_tnl_
        p->flowinfo = u->flowinfo;
        p->link = u->link;
        p->proto = u->proto;
        p->flowinfo = u->flowinfo;
        p->link = u->link;
        p->proto = u->proto;
@@ -346,7 +346,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
        memcpy(p->name, u->name, sizeof(u->name));
  }
  
        memcpy(p->name, u->name, sizeof(u->name));
  }
  
-@@ -1712,6 +1871,15 @@ static int ip6_tnl_validate(struct nlatt
+@@ -1722,6 +1881,15 @@ static int ip6_tnl_validate(struct nlatt
        return 0;
  }
  
        return 0;
  }
  
@@ -362,7 +362,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
  static void ip6_tnl_netlink_parms(struct nlattr *data[],
                                  struct __ip6_tnl_parm *parms)
  {
  static void ip6_tnl_netlink_parms(struct nlattr *data[],
                                  struct __ip6_tnl_parm *parms)
  {
-@@ -1743,6 +1911,46 @@ static void ip6_tnl_netlink_parms(struct
+@@ -1753,6 +1921,46 @@ static void ip6_tnl_netlink_parms(struct
  
        if (data[IFLA_IPTUN_PROTO])
                parms->proto = nla_get_u8(data[IFLA_IPTUN_PROTO]);
  
        if (data[IFLA_IPTUN_PROTO])
                parms->proto = nla_get_u8(data[IFLA_IPTUN_PROTO]);
@@ -409,7 +409,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
  }
  
  static int ip6_tnl_newlink(struct net *src_net, struct net_device *dev,
  }
  
  static int ip6_tnl_newlink(struct net *src_net, struct net_device *dev,
-@@ -1795,6 +2003,12 @@ static void ip6_tnl_dellink(struct net_d
+@@ -1805,6 +2013,12 @@ static void ip6_tnl_dellink(struct net_d
  
  static size_t ip6_tnl_get_size(const struct net_device *dev)
  {
  
  static size_t ip6_tnl_get_size(const struct net_device *dev)
  {
@@ -422,7 +422,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
        return
                /* IFLA_IPTUN_LINK */
                nla_total_size(4) +
        return
                /* IFLA_IPTUN_LINK */
                nla_total_size(4) +
-@@ -1812,6 +2026,24 @@ static size_t ip6_tnl_get_size(const str
+@@ -1822,6 +2036,24 @@ static size_t ip6_tnl_get_size(const str
                nla_total_size(4) +
                /* IFLA_IPTUN_PROTO */
                nla_total_size(1) +
                nla_total_size(4) +
                /* IFLA_IPTUN_PROTO */
                nla_total_size(1) +
@@ -447,7 +447,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
                0;
  }
  
                0;
  }
  
-@@ -1819,6 +2051,9 @@ static int ip6_tnl_fill_info(struct sk_b
+@@ -1829,6 +2061,9 @@ static int ip6_tnl_fill_info(struct sk_b
  {
        struct ip6_tnl *tunnel = netdev_priv(dev);
        struct __ip6_tnl_parm *parm = &tunnel->parms;
  {
        struct ip6_tnl *tunnel = netdev_priv(dev);
        struct __ip6_tnl_parm *parm = &tunnel->parms;
@@ -457,7 +457,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
  
        if (nla_put_u32(skb, IFLA_IPTUN_LINK, parm->link) ||
            nla_put_in6_addr(skb, IFLA_IPTUN_LOCAL, &parm->laddr) ||
  
        if (nla_put_u32(skb, IFLA_IPTUN_LINK, parm->link) ||
            nla_put_in6_addr(skb, IFLA_IPTUN_LOCAL, &parm->laddr) ||
-@@ -1827,8 +2062,27 @@ static int ip6_tnl_fill_info(struct sk_b
+@@ -1837,8 +2072,27 @@ static int ip6_tnl_fill_info(struct sk_b
            nla_put_u8(skb, IFLA_IPTUN_ENCAP_LIMIT, parm->encap_limit) ||
            nla_put_be32(skb, IFLA_IPTUN_FLOWINFO, parm->flowinfo) ||
            nla_put_u32(skb, IFLA_IPTUN_FLAGS, parm->flags) ||
            nla_put_u8(skb, IFLA_IPTUN_ENCAP_LIMIT, parm->encap_limit) ||
            nla_put_be32(skb, IFLA_IPTUN_FLOWINFO, parm->flowinfo) ||
            nla_put_u32(skb, IFLA_IPTUN_FLAGS, parm->flags) ||
@@ -486,7 +486,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
        return 0;
  
  nla_put_failure:
        return 0;
  
  nla_put_failure:
-@@ -1852,6 +2106,7 @@ static const struct nla_policy ip6_tnl_p
+@@ -1862,6 +2116,7 @@ static const struct nla_policy ip6_tnl_p
        [IFLA_IPTUN_FLOWINFO]           = { .type = NLA_U32 },
        [IFLA_IPTUN_FLAGS]              = { .type = NLA_U32 },
        [IFLA_IPTUN_PROTO]              = { .type = NLA_U8 },
        [IFLA_IPTUN_FLOWINFO]           = { .type = NLA_U32 },
        [IFLA_IPTUN_FLAGS]              = { .type = NLA_U32 },
        [IFLA_IPTUN_PROTO]              = { .type = NLA_U8 },
index eff8e829a6419041c2f66abe6495c378a76e3670..0794d891c8a27a1590213fd97dfb8aaf54bfa8d2 100644 (file)
@@ -17,7 +17,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/net/core/dev.c
 +++ b/net/core/dev.c
 
 --- a/net/core/dev.c
 +++ b/net/core/dev.c
-@@ -4224,6 +4224,9 @@ static enum gro_result dev_gro_receive(s
+@@ -4219,6 +4219,9 @@ static enum gro_result dev_gro_receive(s
        enum gro_result ret;
        int grow;
  
        enum gro_result ret;
        int grow;
  
@@ -27,7 +27,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        if (!(skb->dev->features & NETIF_F_GRO))
                goto normal;
  
        if (!(skb->dev->features & NETIF_F_GRO))
                goto normal;
  
-@@ -5383,6 +5386,48 @@ static void __netdev_adjacent_dev_unlink
+@@ -5378,6 +5381,48 @@ static void __netdev_adjacent_dev_unlink
                                           &upper_dev->adj_list.lower);
  }
  
                                           &upper_dev->adj_list.lower);
  }
  
@@ -76,7 +76,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  static int __netdev_upper_dev_link(struct net_device *dev,
                                   struct net_device *upper_dev, bool master,
                                   void *private)
  static int __netdev_upper_dev_link(struct net_device *dev,
                                   struct net_device *upper_dev, bool master,
                                   void *private)
-@@ -5454,6 +5499,7 @@ static int __netdev_upper_dev_link(struc
+@@ -5449,6 +5494,7 @@ static int __netdev_upper_dev_link(struc
                        goto rollback_lower_mesh;
        }
  
                        goto rollback_lower_mesh;
        }
  
@@ -84,7 +84,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        call_netdevice_notifiers_info(NETDEV_CHANGEUPPER, dev,
                                      &changeupper_info.info);
        return 0;
        call_netdevice_notifiers_info(NETDEV_CHANGEUPPER, dev,
                                      &changeupper_info.info);
        return 0;
-@@ -5580,6 +5626,7 @@ void netdev_upper_dev_unlink(struct net_
+@@ -5575,6 +5621,7 @@ void netdev_upper_dev_unlink(struct net_
        list_for_each_entry(i, &upper_dev->all_adj_list.upper, list)
                __netdev_adjacent_dev_unlink(dev, i->dev, i->ref_nr);
  
        list_for_each_entry(i, &upper_dev->all_adj_list.upper, list)
                __netdev_adjacent_dev_unlink(dev, i->dev, i->ref_nr);
  
@@ -92,7 +92,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        call_netdevice_notifiers_info(NETDEV_CHANGEUPPER, dev,
                                      &changeupper_info.info);
  }
        call_netdevice_notifiers_info(NETDEV_CHANGEUPPER, dev,
                                      &changeupper_info.info);
  }
-@@ -6120,6 +6167,7 @@ int dev_set_mac_address(struct net_devic
+@@ -6115,6 +6162,7 @@ int dev_set_mac_address(struct net_devic
        if (err)
                return err;
        dev->addr_assign_type = NET_ADDR_SET;
        if (err)
                return err;
        dev->addr_assign_type = NET_ADDR_SET;
@@ -102,7 +102,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        return 0;
 --- a/include/linux/netdevice.h
 +++ b/include/linux/netdevice.h
        return 0;
 --- a/include/linux/netdevice.h
 +++ b/include/linux/netdevice.h
-@@ -1637,6 +1637,8 @@ struct net_device {
+@@ -1639,6 +1639,8 @@ struct net_device {
        struct netdev_hw_addr_list      mc;
        struct netdev_hw_addr_list      dev_addrs;
  
        struct netdev_hw_addr_list      mc;
        struct netdev_hw_addr_list      dev_addrs;
  
index 7f288f884c3d91b8d9e28aa9ebca09313063a91a..8333dcca8f78803405a2f7f906db2f80558f8d7c 100644 (file)
@@ -16,7 +16,7 @@
  
  /**
   *    struct net_device - The DEVICE structure.
  
  /**
   *    struct net_device - The DEVICE structure.
-@@ -1602,6 +1604,11 @@ struct net_device {
+@@ -1603,6 +1605,11 @@ struct net_device {
        const struct l3mdev_ops *l3mdev_ops;
  #endif
  
        const struct l3mdev_ops *l3mdev_ops;
  #endif
  
@@ -28,7 +28,7 @@
        const struct header_ops *header_ops;
  
        unsigned int            flags;
        const struct header_ops *header_ops;
  
        unsigned int            flags;
-@@ -1668,6 +1675,10 @@ struct net_device {
+@@ -1670,6 +1677,10 @@ struct net_device {
        struct mpls_dev __rcu   *mpls_ptr;
  #endif
  
        struct mpls_dev __rcu   *mpls_ptr;
  #endif
  
@@ -86,7 +86,7 @@
        help
 --- a/net/core/dev.c
 +++ b/net/core/dev.c
        help
 --- a/net/core/dev.c
 +++ b/net/core/dev.c
-@@ -2713,10 +2713,20 @@ static int xmit_one(struct sk_buff *skb,
+@@ -2708,10 +2708,20 @@ static int xmit_one(struct sk_buff *skb,
        if (!list_empty(&ptype_all) || !list_empty(&dev->ptype_all))
                dev_queue_xmit_nit(skb, dev);
  
        if (!list_empty(&ptype_all) || !list_empty(&dev->ptype_all))
                dev_queue_xmit_nit(skb, dev);
  
index d30be32e67cd632c5d884d967c872605dc5e1255..f5a2ed73cc8c10748e99e8dd7fd4929754d190d1 100644 (file)
@@ -10,11 +10,9 @@ Signed-off-by: Shaohui Xie <Shaohui.Xie@nxp.com>
  drivers/net/ethernet/freescale/sdk_dpaa/mac-api.c | 8 ++++++--
  1 file changed, 6 insertions(+), 2 deletions(-)
 
  drivers/net/ethernet/freescale/sdk_dpaa/mac-api.c | 8 ++++++--
  1 file changed, 6 insertions(+), 2 deletions(-)
 
-diff --git a/drivers/net/ethernet/freescale/sdk_dpaa/mac-api.c b/drivers/net/ethernet/freescale/sdk_dpaa/mac-api.c
-index aaedaae..c092afb 100644
 --- a/drivers/net/ethernet/freescale/sdk_dpaa/mac-api.c
 +++ b/drivers/net/ethernet/freescale/sdk_dpaa/mac-api.c
 --- a/drivers/net/ethernet/freescale/sdk_dpaa/mac-api.c
 +++ b/drivers/net/ethernet/freescale/sdk_dpaa/mac-api.c
-@@ -409,6 +409,10 @@ void get_pause_cfg(struct mac_device *mac_dev, bool *rx_pause, bool *tx_pause)
+@@ -409,6 +409,10 @@ void get_pause_cfg(struct mac_device *ma
  }
  EXPORT_SYMBOL(get_pause_cfg);
  
  }
  EXPORT_SYMBOL(get_pause_cfg);
  
@@ -25,7 +23,7 @@ index aaedaae..c092afb 100644
  static void adjust_link(struct net_device *net_dev)
  {
        struct dpa_priv_s *priv = netdev_priv(net_dev);
  static void adjust_link(struct net_device *net_dev)
  {
        struct dpa_priv_s *priv = netdev_priv(net_dev);
-@@ -473,7 +477,7 @@ static int xgmac_init_phy(struct net_device *net_dev,
+@@ -473,7 +477,7 @@ static int xgmac_init_phy(struct net_dev
                                     mac_dev->phy_if);
        else
                phy_dev = of_phy_connect(net_dev, mac_dev->phy_node,
                                     mac_dev->phy_if);
        else
                phy_dev = of_phy_connect(net_dev, mac_dev->phy_node,
@@ -34,7 +32,7 @@ index aaedaae..c092afb 100644
        if (unlikely(phy_dev == NULL) || IS_ERR(phy_dev)) {
                netdev_err(net_dev, "Could not attach to PHY %s\n",
                                mac_dev->phy_node ?
        if (unlikely(phy_dev == NULL) || IS_ERR(phy_dev)) {
                netdev_err(net_dev, "Could not attach to PHY %s\n",
                                mac_dev->phy_node ?
-@@ -506,7 +510,7 @@ static int memac_init_phy(struct net_device *net_dev,
+@@ -506,7 +510,7 @@ static int memac_init_phy(struct net_dev
                        return 0;
                } else
                        phy_dev = of_phy_connect(net_dev, mac_dev->phy_node,
                        return 0;
                } else
                        phy_dev = of_phy_connect(net_dev, mac_dev->phy_node,
@@ -43,6 +41,3 @@ index aaedaae..c092afb 100644
                                                 mac_dev->phy_if);
        } else {
                if (!mac_dev->phy_node)
                                                 mac_dev->phy_if);
        } else {
                if (!mac_dev->phy_node)
--- 
-2.1.0.27.g96db324
-