make sure that when the kernel config changes, compile is triggered for all kernel...
authorFelix Fietkau <nbd@openwrt.org>
Tue, 2 Sep 2008 15:50:09 +0000 (15:50 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 2 Sep 2008 15:50:09 +0000 (15:50 +0000)
SVN-Revision: 12503

include/kernel.mk

index 8393d2f4209be060a3e8c45a7eb391b560b1bc53..5232148a6b4fa833faa56183d1aaa3df24fa302e 100644 (file)
@@ -126,6 +126,8 @@ $(call KernelPackage/$(1)/config)
     endef
   endif
 
+  $(STAMP_BUILT): $(LINUX_DIR)/.config
+
   ifneq ($(if $(filter-out %=y %=n %=m,$(KCONFIG)),$(filter m,$(foreach c,$(filter-out %=y %=n %=m,$(KCONFIG)),$($(c)))),.),)
     ifneq ($(strip $(FILES)),)
       define Package/kmod-$(1)/install