build: add PKG_SOURCE_URL_FILE support
authorKamil Wcislo <kamil.wcislo@lpnplant.io>
Thu, 5 Jul 2018 19:40:19 +0000 (21:40 +0200)
committerMatthias Schiffer <mschiffer@universe-factory.net>
Sat, 23 Nov 2019 12:35:43 +0000 (13:35 +0100)
It seems that there is a missing PKG_SOURCE_URL_FILE support.
This little fix adds the support for packages to change the name of the
downloaded file.

Sometimes it is desirable to change the downloaded archive file name, like
for mitigating name conflicts for different packages (some files on the server
could be named like, e.g. 2018-01-01.tar.gz) or for the cases that there is
no name for the file in the URL (e.g. http://someserver.com/download).

Signed-off-by: Kamil Wcislo <kamil.wcislo@lpnplant.io>
Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
include/download.mk

index 09794e155e9f2ab17918d21dcf8d9930d66efe65..14d68bf8f5e929fb4bdf6908f0d428c2d584f19e 100644 (file)
@@ -289,6 +289,7 @@ endef
 define Download/default
   FILE:=$(PKG_SOURCE)
   URL:=$(PKG_SOURCE_URL)
+  URL_FILE:=$(PKG_SOURCE_URL_FILE)
   SUBDIR:=$(PKG_SOURCE_SUBDIR)
   PROTO:=$(PKG_SOURCE_PROTO)
   $(if $(PKG_SOURCE_MIRROR),MIRROR:=$(filter 1,$(PKG_MIRROR)))