busybox 1.19.4 update patch
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 18 Mar 2012 19:46:52 +0000 (19:46 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 18 Mar 2012 19:46:52 +0000 (19:46 +0000)
This patch updates busybox to 1.19.4 and refreshes all patches.

Signed-off-by: Peter Wagner <tripolar@gmx.at>
SVN-Revision: 30985

package/busybox/Makefile
package/busybox/patches/000-upstream-getty.patch [deleted file]
package/busybox/patches/000-upstream-modinfo.patch [deleted file]
package/busybox/patches/004-upstream-percent_decode_in_place.patch
package/busybox/patches/110-wget_getopt_fix.patch
package/busybox/patches/244-udhcpc_add_6rd_option.patch
package/busybox/patches/310-passwd_access.patch
package/busybox/patches/340-lock_util.patch
package/busybox/patches/803-id_getgrouplist.patch

index 41e7d40bd3e874480d74f5b4352e721015e4fc20..af27df071bc1f373c37db6738943eb99f546ce79 100644 (file)
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=busybox
-PKG_VERSION:=1.19.3
-PKG_RELEASE:=10
+PKG_VERSION:=1.19.4
+PKG_RELEASE:=1
 PKG_FLAGS:=essential
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.busybox.net/downloads \
                http://distfiles.gentoo.org/distfiles/
-PKG_MD5SUM:=c3938e1ac59602387009bbf1dd1af7f6
+PKG_MD5SUM:=9c0cae5a0379228e7b55e5b29528df8e
 
 PKG_BUILD_DEPENDS:=BUSYBOX_USE_LIBRPC:librpc
 PKG_BUILD_PARALLEL:=1
diff --git a/package/busybox/patches/000-upstream-getty.patch b/package/busybox/patches/000-upstream-getty.patch
deleted file mode 100644 (file)
index 74a2f95..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/loginutils/getty.c
-+++ b/loginutils/getty.c
-@@ -271,7 +271,9 @@ static void termios_init(int speed)
- #ifdef CMSPAR
-               | CMSPAR  /* mark or space parity */
- #endif
-+#ifdef CBAUD
-               | CBAUD   /* (output) baud rate */
-+#endif
- #ifdef CBAUDEX
-               | CBAUDEX /* (output) baud rate */
- #endif
diff --git a/package/busybox/patches/000-upstream-modinfo.patch b/package/busybox/patches/000-upstream-modinfo.patch
deleted file mode 100644 (file)
index 1b11d44..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/modutils/modinfo.c
-+++ b/modutils/modinfo.c
-@@ -13,6 +13,7 @@
- //config:config MODINFO
- //config:     bool "modinfo"
- //config:     default y
-+//config:     select PLATFORM_LINUX
- //config:     help
- //config:       Show information about a Linux Kernel module
index 83d68f3470af722c1cad98eec17530c7e7aad532..d94ee479000157f95442889a1d9cfc645d8088d5 100644 (file)
@@ -222,7 +222,7 @@ Signed-off-by: Denys Vlasenko <vda.linux@googlemail.com>
                h->host = sp + 1;
        }
  
-@@ -660,12 +665,6 @@ static void download_one_url(const char 
+@@ -661,12 +666,6 @@ static void download_one_url(const char
  
  #if ENABLE_FEATURE_WGET_AUTHENTICATION
                if (target.user) {
index 52b9d94be060b1595bb1ab16951622b8d4dec505..10032314627a9401c617f9950f0f88b531930fcf 100644 (file)
@@ -1,6 +1,6 @@
 --- a/networking/wget.c
 +++ b/networking/wget.c
-@@ -871,7 +871,7 @@ int wget_main(int argc UNUSED_PARAM, cha
+@@ -873,7 +873,7 @@ int wget_main(int argc UNUSED_PARAM, cha
                /* Ignored: */
                // "tries\0"            Required_argument "t"
                /* Ignored (we always use PASV): */
index 84891d3cdb023395523d3fd50c3ec8f24090fc13..9e30ef79a778408058d1f0e4359a7adbff51a3cd 100644 (file)
@@ -9,7 +9,7 @@
        { OPTION_STRING                           , 0xfc }, /* DHCP_WPAD          */
  
        /* Options below have no match in dhcp_option_strings[],
-@@ -127,6 +129,8 @@ const char dhcp_option_strings[] ALIGN1 
+@@ -127,6 +129,8 @@ const char dhcp_option_strings[] ALIGN1
        "vlanpriority" "\0"/* DHCP_VLAN_PRIORITY  */
  #endif
        "msstaticroutes""\0"/* DHCP_MS_STATIC_ROUTES */
@@ -46,7 +46,7 @@
        [OPTION_STRING          ] = 1,
  #if ENABLE_FEATURE_UDHCP_RFC3397
        [OPTION_DNS_STRING      ] = 1, /* unused */
-@@ -123,6 +124,23 @@ static int sprint_nip(char *dest, const 
+@@ -123,6 +124,23 @@ static int sprint_nip(char *dest, const
        return sprintf(dest, "%s%u.%u.%u.%u", pre, ip[0], ip[1], ip[2], ip[3]);
  }
  
  /* really simple implementation, just count the bits */
  static int mton(uint32_t mask)
  {
-@@ -232,6 +250,70 @@ static NOINLINE char *xmalloc_optname_op
+@@ -231,6 +249,70 @@ static NOINLINE char *xmalloc_optname_op
+                       }
  
                        return ret;
-               }
++              }
 +              case OPTION_6RD: {
 +                      /* Option binary format:
 +                       *  0                   1                   2                   3
 +                      }
 +
 +                      return ret;
-+              }
+               }
  #if ENABLE_FEATURE_UDHCP_RFC3397
                case OPTION_DNS_STRING:
-                       /* unpack option into dest; use ret for prefix (i.e., "optname=") */
index b995599de7f1ad9c85074634cbcd3c9348f2e9b4..daa1b999836b3d7184c59b88f307be92ce95be3b 100644 (file)
@@ -3,7 +3,7 @@
 
 --- a/networking/httpd.c
 +++ b/networking/httpd.c
-@@ -1700,21 +1700,32 @@ static int check_user_passwd(const char 
+@@ -1700,21 +1700,32 @@ static int check_user_passwd(const char
  
                if (ENABLE_FEATURE_HTTPD_AUTH_MD5) {
                        char *md5_passwd;
index fd657b698cc581353ad89338a6ac665e3817b7d4..eb346421a48cceb4fbe34e6790df2ccf60750cf9 100644 (file)
@@ -1,6 +1,6 @@
 --- a/include/applets.src.h
 +++ b/include/applets.src.h
-@@ -218,6 +218,7 @@ IF_LN(APPLET_NOEXEC(ln, ln, BB_DIR_BIN, 
+@@ -218,6 +218,7 @@ IF_LN(APPLET_NOEXEC(ln, ln, BB_DIR_BIN,
  IF_LOAD_POLICY(APPLET(load_policy, BB_DIR_USR_SBIN, BB_SUID_DROP))
  IF_LOADFONT(APPLET(loadfont, BB_DIR_USR_SBIN, BB_SUID_DROP))
  IF_LOADKMAP(APPLET(loadkmap, BB_DIR_SBIN, BB_SUID_DROP))
index 66c184959f78fa11dc9e0008cda834cd50d228ac..638305ee7ed0b67f941c0e5c3c166c9fcb6d9c8e 100644 (file)
@@ -31,7 +31,7 @@ Signed-off-by: Nicolas Thill <nico@openwrt.org>
                /* I guess *n < 0 might indicate error. Anyway,
                 * malloc'ing -1 bytes won't be good, so: */
                if (*n < 0)
-@@ -210,6 +216,7 @@ int id_main(int argc UNUSED_PARAM, char 
+@@ -210,6 +216,7 @@ int id_main(int argc UNUSED_PARAM, char
                        if (egid != rgid)
                                status |= print_group(egid, " ");
                }
@@ -39,7 +39,7 @@ Signed-off-by: Nicolas Thill <nico@openwrt.org>
                /* We are supplying largish buffer, trying
                 * to not run get_groups() twice. That might be slow
                 * ("user database in remote SQL server" case) */
-@@ -236,6 +243,7 @@ int id_main(int argc UNUSED_PARAM, char 
+@@ -236,6 +243,7 @@ int id_main(int argc UNUSED_PARAM, char
                }
                if (ENABLE_FEATURE_CLEAN_UP)
                        free(groups);