ncurses: revert $(STAGING_DIR_HOSTPKG) to $(STAGING_DIR)/host where appropriate
authorMatthias Schiffer <mschiffer@universe-factory.net>
Sat, 14 Jan 2017 17:11:26 +0000 (18:11 +0100)
committerMatthias Schiffer <mschiffer@universe-factory.net>
Sat, 14 Jan 2017 17:58:44 +0000 (18:58 +0100)
Host files installed in Build/InstallDev are target-specific and will stay
in $(STAGING_DIR)/host after the STAGING_DIR_HOSTPKG unification.

Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
package/libs/ncurses/Makefile

index 88a31e299b0a68fa2d7422d8749dbfa44e012f9e..60a8a176df3c2eb05aa95238f96660b5976806a1 100644 (file)
@@ -135,7 +135,7 @@ define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/ncursesw6-config $(2)/bin/
        $(SED) 's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' -e 's/$$$$INCS //g' \
                $(2)/bin/ncursesw6-config
-       ln -sf $(STAGING_DIR_HOSTPKG)/bin/ncursesw6-config $(1)/usr/bin/ncursesw6-config
+       ln -sf $(STAGING_DIR)/host/bin/ncursesw6-config $(1)/usr/bin/ncursesw6-config
 endef
 
 define Host/Compile