gre: introduce 'nohostroute' option
authorFabian Bläse <fabian@blaese.de>
Wed, 29 May 2019 19:08:01 +0000 (21:08 +0200)
committerHans Dedecker <dedeckeh@gmail.com>
Fri, 31 May 2019 07:42:32 +0000 (09:42 +0200)
It is not always necessary to add a host route for the gre peer address.

This introduces a new config option 'nohostroute' (similar to the
option introduced for wireguard in d8e2e19) to allow to disable
the creation of those routes explicitely.

Signed-off-by: Fabian Bläse <fabian@blaese.de>
Signed-off-by: Hans Dedecker <dedeckeh@gmail.com> [PKG_RELEASE increase]
package/network/config/gre/Makefile
package/network/config/gre/files/gre.sh

index 6fe6d567b91cd9c9d4c8799d04e1fa6c6a178216..83ec8988af6860c817a3a447e5d28b49f21eeac5 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gre
 PKG_VERSION:=1
-PKG_RELEASE:=10
+PKG_RELEASE:=11
 PKG_LICENSE:=GPL-2.0
 
 include $(INCLUDE_DIR)/package.mk
index 2bb1010b76aa30ecd07082e81c756089eb1273a3..3414ed304796ea35911ecb8b27f397d530ad7405 100755 (executable)
@@ -56,7 +56,7 @@ gre_setup() {
        local remoteip
 
        local ipaddr peeraddr
-       json_get_vars df ipaddr peeraddr tunlink
+       json_get_vars df ipaddr peeraddr tunlink nohostroute
 
        [ -z "$peeraddr" ] && {
                proto_notify_error "$cfg" "MISSING_PEER_ADDRESS"
@@ -76,7 +76,9 @@ gre_setup() {
                break
        done
 
-       ( proto_add_host_dependency "$cfg" "$peeraddr" "$tunlink" )
+       if [ "${nohostroute}" != "1" ]; then
+               ( proto_add_host_dependency "$cfg" "$peeraddr" "$tunlink" )
+       fi
 
        [ -z "$ipaddr" ] && {
                local wanif="$tunlink"
@@ -133,7 +135,7 @@ grev6_setup() {
        local remoteip6
 
        local ip6addr peer6addr weakif
-       json_get_vars ip6addr peer6addr tunlink weakif encaplimit
+       json_get_vars ip6addr peer6addr tunlink weakif encaplimit nohostroute
 
        [ -z "$peer6addr" ] && {
                proto_notify_error "$cfg" "MISSING_PEER_ADDRESS"
@@ -153,7 +155,9 @@ grev6_setup() {
                break
        done
 
-       ( proto_add_host_dependency "$cfg" "$peer6addr" "$tunlink" )
+       if [ "${nohostroute}" != "1" ]; then
+               ( proto_add_host_dependency "$cfg" "$peer6addr" "$tunlink" )
+       fi
 
        [ -z "$ip6addr" ] && {
                local wanif="$tunlink"
@@ -262,6 +266,7 @@ proto_gre_init_config() {
        proto_config_add_string "ipaddr"
        proto_config_add_string "peeraddr"
        proto_config_add_boolean "df"
+       proto_config_add_boolean "nohostroute"
 }
 
 proto_gretap_init_config() {
@@ -275,6 +280,7 @@ proto_grev6_init_config() {
        proto_config_add_string "peer6addr"
        proto_config_add_string "weakif"
        proto_config_add_string "encaplimit"
+       proto_config_add_boolean "nohostroute"
 }
 
 proto_grev6tap_init_config() {