util-linux: unconditionally enable ncursesw support
authorFelix Fietkau <nbd@nbd.name>
Wed, 22 Mar 2017 12:49:05 +0000 (13:49 +0100)
committerFelix Fietkau <nbd@nbd.name>
Tue, 11 Apr 2017 17:33:00 +0000 (19:33 +0200)
The build dependency is unconditional, and some components might fail if
ncurses is not available

Signed-off-by: Felix Fietkau <nbd@nbd.name>
package/utils/util-linux/Makefile

index f85f48e7562cd89ebcc11cabf155fcffd127d823..a3c59c073b54a99bf12ed356214f6e3c305a3a53 100644 (file)
@@ -27,11 +27,6 @@ PKG_LICENSE_FILES:=  COPYING                                 \
 
 PKG_BUILD_PARALLEL:=0
 
 
 PKG_BUILD_PARALLEL:=0
 
-PKG_CONFIG_DEPENDS:= \
-       CONFIG_PACKAGE_cal \
-       CONFIG_PACKAGE_cfdisk \
-       CONFIG_PACKAGE_setterm
-
 PKG_FIXUP:=autoreconf
 PKG_INSTALL:=1
 
 PKG_FIXUP:=autoreconf
 PKG_INSTALL:=1
 
@@ -441,7 +436,7 @@ CONFIGURE_ARGS += \
        --without-udev          \
        --without-readline      \
        --disable-more          \
        --without-udev          \
        --without-readline      \
        --disable-more          \
-       $(if $(CONFIG_PACKAGE_cal)$(CONFIG_PACKAGE_cfdisk)$(CONFIG_PACKAGE_setterm),--with-ncursesw,--without-ncurses)
+       --with-ncursesw
 
 TARGET_CFLAGS += $(FPIC) -std=gnu99
 
 
 TARGET_CFLAGS += $(FPIC) -std=gnu99