move certain host related variables to .host.mk generated by include/host-build.mk...
authorFelix Fietkau <nbd@openwrt.org>
Tue, 10 Oct 2006 13:25:18 +0000 (13:25 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 10 Oct 2006 13:25:18 +0000 (13:25 +0000)
SVN-Revision: 5012

openwrt/include/host-build.mk
openwrt/rules.mk

index c19cb8fd1c2cfd257757ee54b033cc758104cf4a..5670b6f17db78992e10a8a5e95fedeeafb9c29ed 100644 (file)
@@ -4,7 +4,26 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-OS:=$(shell uname)
+
+include $(TOPDIR)/.host.mk
+
+$(TOPDIR)/.host.mk: $(INCLUDE_DIR)/host-build.mk
+       echo "HOST_OS:=`uname`" > $@
+       echo "HOST_ARCH:=` \
+               $(HOSTCC) -dumpmachine | sed -e s'/-.*//' \
+                       -e 's/sparc.*/sparc/' \
+                       -e 's/arm.*/arm/' \
+                       -e 's/m68k.*/m68k/' \
+                       -e 's/ppc/powerpc/' \
+                       -e 's/v850.*/v850/' \
+                       -e 's/sh[234]/sh/' \
+                       -e 's/mips-.*/mips/' \
+                       -e 's/mipsel-.*/mipsel/' \
+                       -e 's/cris.*/cris/' \
+                       -e 's/i[3-9]86/i386/'`" >> $@
+       echo "GNU_HOST_NAME:=`$(HOSTCC) -dumpmachine`" >> $@
+
+
 ifneq ($(strip $(PKG_CAT)),)
   ifeq ($(PKG_CAT),unzip)
     UNPACK=unzip -d $(PKG_BUILD_DIR) $(DL_DIR)/$(PKG_SOURCE)
 ifneq ($(strip $(PKG_CAT)),)
   ifeq ($(PKG_CAT),unzip)
     UNPACK=unzip -d $(PKG_BUILD_DIR) $(DL_DIR)/$(PKG_SOURCE)
index 0ec5daf086e354ba60fc884dabbf7a0c2da2fcc7..84163ba225218c6d7fd621a27db9de3da2731295 100644 (file)
@@ -64,21 +64,6 @@ ifneq ($(CONFIG_CCACHE),)
   TARGET_CC:= ccache $(TARGET_CC)
 endif
 
   TARGET_CC:= ccache $(TARGET_CC)
 endif
 
-HOST_ARCH:=$(shell $(HOSTCC) -dumpmachine | sed -e s'/-.*//' \
-       -e 's/sparc.*/sparc/' \
-       -e 's/arm.*/arm/' \
-       -e 's/m68k.*/m68k/' \
-       -e 's/ppc/powerpc/' \
-       -e 's/v850.*/v850/' \
-       -e 's/sh[234]/sh/' \
-       -e 's/mips-.*/mips/' \
-       -e 's/mipsel-.*/mipsel/' \
-       -e 's/cris.*/cris/' \
-       -e 's/i[3-9]86/i386/' \
-       )
-
-GNU_HOST_NAME:=$(shell $(HOSTCC) -dumpmachine)
-
 TARGET_CONFIGURE_OPTS:= \
   AR=$(TARGET_CROSS)ar \
   AS="$(TARGET_CC) -c $(TARGET_CFLAGS)" \
 TARGET_CONFIGURE_OPTS:= \
   AR=$(TARGET_CROSS)ar \
   AS="$(TARGET_CC) -c $(TARGET_CFLAGS)" \