dropbear: update to 2016.73
authorJo-Philipp Wich <jo@mein.io>
Thu, 12 May 2016 08:21:23 +0000 (10:21 +0200)
committerJo-Philipp Wich <jo@mein.io>
Fri, 13 May 2016 08:23:52 +0000 (10:23 +0200)
Update the dropbear package to version 2016.73, refresh patches.
The measured .ipk sizes on an x86_64 build are:

  94588 dropbear_2015.71-3_x86_64.ipk
  95316 dropbear_2016.73-1_x86_64.ipk

This is an increase of roughly 700 bytes after compression.

Tested-by: Kevin Darbyshire-Bryant <kevin@darbyshire-bryant.me.uk>
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/network/services/dropbear/Makefile
package/network/services/dropbear/patches/120-openwrt_options.patch
package/network/services/dropbear/patches/130-ssh_ignore_o_and_x_args.patch [deleted file]
package/network/services/dropbear/patches/130-ssh_ignore_x_args.patch [new file with mode: 0644]
package/network/services/dropbear/patches/140-disable_assert.patch
package/network/services/dropbear/patches/500-set-default-path.patch

index ef57502e69896d7a4643b6c4a467b98d805cebfe..6e5112c67f7d905c4829436bc0338d87692b3d57 100644 (file)
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dropbear
-PKG_VERSION:=2015.71
-PKG_RELEASE:=3
+PKG_VERSION:=2016.73
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:= \
        http://matt.ucc.asn.au/dropbear/releases/ \
        https://dropbear.nl/mirror/releases/
-PKG_MD5SUM:=2ccc0a2f3e37ca221db12c5af6a88137
+PKG_MD5SUM:=8d6d78ce60ca52350ec04fcbd711ce9b
 
 PKG_LICENSE:=MIT
 PKG_LICENSE_FILES:=LICENSE libtomcrypt/LICENSE libtommath/LICENSE
index f0202080909e2e8ec553c03f66df20dc7e036216..f16aaf001eee11811be81fa1db399cf117e66595 100644 (file)
@@ -61,7 +61,7 @@
  /* ECDSA is significantly faster than RSA or DSS. Compiling in ECC
   * code (either ECDSA or ECDH) increases binary size - around 30kB
   * on x86-64 */
-@@ -189,7 +189,7 @@ If you test it please contact the Dropbe
+@@ -194,7 +194,7 @@ If you test it please contact the Dropbe
  
  /* Whether to print the message of the day (MOTD). This doesn't add much code
   * size */
@@ -70,7 +70,7 @@
  
  /* The MOTD file path */
  #ifndef MOTD_FILENAME
-@@ -237,7 +237,7 @@ Homedir is prepended unless path begins
+@@ -242,7 +242,7 @@ Homedir is prepended unless path begins
   * note that it will be provided for all "hidden" client-interactive
   * style prompts - if you want something more sophisticated, use 
   * SSH_ASKPASS instead. Comment out this var to remove this functionality.*/
diff --git a/package/network/services/dropbear/patches/130-ssh_ignore_o_and_x_args.patch b/package/network/services/dropbear/patches/130-ssh_ignore_o_and_x_args.patch
deleted file mode 100644 (file)
index bf1641b..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
---- a/cli-runopts.c
-+++ b/cli-runopts.c
-@@ -284,6 +284,10 @@ void cli_getopts(int argc, char ** argv)
-                                       debug_trace = 1;
-                                       break;
- #endif
-+                              case 'o':
-+                                      next = &dummy;
-+                              case 'x':
-+                                      break;
-                               case 'F':
-                               case 'e':
- #ifndef ENABLE_USER_ALGO_LIST
-@@ -301,7 +305,6 @@ void cli_getopts(int argc, char ** argv)
-                                       print_version();
-                                       exit(EXIT_SUCCESS);
-                                       break;
--                              case 'o':
-                               case 'b':
-                                       next = &dummy;
-                               default:
diff --git a/package/network/services/dropbear/patches/130-ssh_ignore_x_args.patch b/package/network/services/dropbear/patches/130-ssh_ignore_x_args.patch
new file mode 100644 (file)
index 0000000..ab09c2f
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/cli-runopts.c
++++ b/cli-runopts.c
+@@ -296,6 +296,8 @@ void cli_getopts(int argc, char ** argv)
+                                       debug_trace = 1;
+                                       break;
+ #endif
++                              case 'x':
++                                      break;
+                               case 'F':
+                               case 'e':
+ #ifndef ENABLE_USER_ALGO_LIST
index 667d69cb38167f7df05f2f17ce0c6af1cdab18ca..78b54acfa0f52a4abbae497ed57a04cca7368c41 100644 (file)
@@ -1,6 +1,6 @@
 --- a/dbutil.h
 +++ b/dbutil.h
-@@ -88,7 +88,11 @@ int m_str_to_uint(const char* str, unsig
+@@ -78,7 +78,11 @@ int m_str_to_uint(const char* str, unsig
  #define DEF_MP_INT(X) mp_int X = {0, 0, 0, NULL}
  
  /* Dropbear assertion */
index 3f65250a9775c6f875ae034e5d853cea97ceb03e..da6b9ae0ce0ae6a270f8c7bc6152cf09efbee15d 100644 (file)
@@ -1,6 +1,6 @@
 --- a/options.h
 +++ b/options.h
-@@ -347,7 +347,9 @@ be overridden at runtime with -I. 0 disa
+@@ -352,7 +352,9 @@ be overridden at runtime with -I. 0 disa
  #define DEFAULT_IDLE_TIMEOUT 0
  
  /* The default path. This will often get replaced by the shell */