build: unsilence move command
authorThomas Reifferscheid <thomas@reifferscheid.org>
Mon, 20 Feb 2017 16:48:50 +0000 (17:48 +0100)
committerFelix Fietkau <nbd@nbd.name>
Wed, 22 Feb 2017 21:52:20 +0000 (22:52 +0100)
The @ sign in front of the "mv" command was significantly suppressing
output to stdout. When reviewing the make/build logs it was tricking
me a whole lot and it mad me lose time. Removing the @ sign will get
stdout and logs right about what happened when.

Signed-off-by: Thomas Reifferscheid <thomas@reifferscheid.org>
include/image-commands.mk

index 49e438954a804f487652603d7e6682716b533c2b..c513f19d3a1244ae2d6cd692b0f2545b393bda1c 100644 (file)
@@ -8,7 +8,7 @@ define Build/uImage
                -O linux -T kernel \
                -C $(1) -a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
                -n '$(if $(UIMAGE_NAME),$(UIMAGE_NAME),$(call toupper,$(LINUX_KARCH)) LEDE Linux-$(LINUX_VERSION))' -d $@ $@.new
-       @mv $@.new $@
+       mv $@.new $@
 endef
 
 define Build/buffalo-enc