only use --wildcards for gnu tar
authorFelix Fietkau <nbd@openwrt.org>
Tue, 10 Oct 2006 17:03:38 +0000 (17:03 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 10 Oct 2006 17:03:38 +0000 (17:03 +0000)
SVN-Revision: 5022

openwrt/include/host.mk
openwrt/toolchain/kernel-headers/Makefile

index b4580e2b7a5376b9729e2856331e1c06b2a4c075..64588814726953c0d9763dc248e35c41f81d934b 100644 (file)
@@ -22,3 +22,7 @@ $(TOPDIR)/.host.mk: $(INCLUDE_DIR)/host.mk
                        -e 's/cris.*/cris/' \
                        -e 's/i[3-9]86/i386/'`" >> $@
        echo "GNU_HOST_NAME:=`$(HOSTCC) -dumpmachine`" >> $@
                        -e 's/cris.*/cris/' \
                        -e 's/i[3-9]86/i386/'`" >> $@
        echo "GNU_HOST_NAME:=`$(HOSTCC) -dumpmachine`" >> $@
+       if tar --version 2>&1 | grep 'GNU' >/dev/null; then \
+               echo "TAR_OPTIONS+=--wildcards" >> $@; \
+       fi
+
index 7b5c06c7819a37f43b96143d38b15194ac31a386..3e2cd2ae8678074d1956870660dd8aaf9814c14a 100644 (file)
@@ -29,9 +29,10 @@ LINUX_KARCH:=$(shell echo $(ARCH) | sed -e 's/i[3-9]86/i386/' \
        -e 's/armeb/arm/' \
 )
 
        -e 's/armeb/arm/' \
 )
 
+
 define Build/Prepare
        mkdir -p $(TOOLCHAIN_BUILD_DIR)
 define Build/Prepare
        mkdir -p $(TOOLCHAIN_BUILD_DIR)
-       bzcat $(DL_DIR)/$(PKG_SOURCE) | tar --wildcards -C $(TOOLCHAIN_BUILD_DIR) $(TAR_OPTIONS) - \
+       bzcat $(DL_DIR)/$(PKG_SOURCE) | tar -C $(TOOLCHAIN_BUILD_DIR) $(TAR_OPTIONS) - \
                linux-$(PKG_VERSION)/include \
                linux-$(PKG_VERSION)/Makefile \
                linux-$(PKG_VERSION)/Rules.make \
                linux-$(PKG_VERSION)/include \
                linux-$(PKG_VERSION)/Makefile \
                linux-$(PKG_VERSION)/Rules.make \