build: fix kmod package build on non-GNU systems
authorFelix Fietkau <nbd@nbd.name>
Mon, 29 May 2017 12:26:36 +0000 (14:26 +0200)
committerFelix Fietkau <nbd@nbd.name>
Wed, 5 Jul 2017 10:49:21 +0000 (12:49 +0200)
BSD paste requires a filename argument, and it accepts - to use stdin as
intended.

Signed-off-by: Felix Fietkau <nbd@nbd.name>
include/kernel.mk

index 5e2111c849b38ce5d18dea695e8c89b9f7fe0933..b1d0e8d927cb462b486cfd645d68963f1b6ab8ff 100644 (file)
@@ -131,7 +131,7 @@ define ModuleAutoLoad
        }; \
        $(3) \
        if [ -n "$$$$$$$$modules" ]; then \
-               modules="$$$$$$$$(echo "$$$$$$$$modules" | tr ' ' '\n' | sort | uniq | paste -s -d' ')"; \
+               modules="$$$$$$$$(echo "$$$$$$$$modules" | tr ' ' '\n' | sort | uniq | paste -s -d' ' -)"; \
                mkdir -p $(2)/etc/modules.d; \
                mkdir -p $(2)/CONTROL; \
                echo "#!/bin/sh" > $(2)/CONTROL/postinst-pkg; \