ath79: fix dsa binding for TP-Link TL-WR941ND v2
authorChuanhong Guo <gch981213@gmail.com>
Sun, 12 Jul 2020 08:14:45 +0000 (16:14 +0800)
committerChuanhong Guo <gch981213@gmail.com>
Sun, 12 Jul 2020 08:17:28 +0000 (16:17 +0800)
upstream changed dt-bindings for marvell 88e6060 to use mdio-device
and dropped support for legacy bindings.
fix it in our local dts.

Fixes: FS#2524
Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
target/linux/ath79/dts/ar9132_tplink_tl-wr941-v2.dts
target/linux/ath79/image/tiny-tp-link.mk

index 1be4d6183ac2901d3cec1e7f200a9f0f4012e267..11de522ae2259fd79d0f748163f4cca5d3460423 100644 (file)
                        linux,default-trigger = "phy0tpt";
                };
        };
+};
 
-       dsa {
-               compatible = "marvell,dsa";
-               #address-cells = <1>;
-               #size-cells = <0>;
+&mdio0 {
+       status = "okay";
 
-               dsa,mii-bus = <&mdio0>;
-               dsa,ethernet = <&eth0>;
+       switch@0 {
+               compatible = "marvell,mv88e6060";
+               reg = <0>;
 
-               switch@0 {
+               ports {
                        #address-cells = <1>;
                        #size-cells = <0>;
-                       reg = <0>;
 
                        port@0 {
                                reg = <0>;
                        port@5 {
                                reg = <5>;
                                label = "cpu";
+                               ethernet = <&eth0>;
                        };
                };
        };
        };
 };
 
-&mdio0 {
-       status = "okay";
-};
-
 &eth0 {
        status = "okay";
 
index 128ed9882ed9fed83c9af5f6f60164e5ea7b3191..0da712c5d4e9fd72d8989b0f5551bb19b7adef9b 100644 (file)
@@ -443,7 +443,7 @@ define Device/tplink_tl-wr941-v2
   TPLINK_HWREV := 2
   SUPPORTED_DEVICES += tl-wr941nd
 endef
-#TARGET_DEVICES += tplink_tl-wr941-v2
+TARGET_DEVICES += tplink_tl-wr941-v2
 
 define Device/tplink_tl-wr941-v4
   $(Device/tplink-4m)