build: fix HOST_CONFIGURE_VARS placement
authorJo-Philipp Wich <jo@mein.io>
Thu, 5 Jan 2017 13:10:31 +0000 (14:10 +0100)
committerJo-Philipp Wich <jo@mein.io>
Thu, 5 Jan 2017 13:21:27 +0000 (14:21 +0100)
Ensure that HOST_CONFIGURE_VARS are set before the actual configure command
instead of passing them as configure command arguments.

This change brings host-build.mk in line with package-defaults.mk and makes
host configure environment variables work as expected.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
include/host-build.mk

index b2f017bee21fa50665eff4584208325523ae0501..f2109851d95ad9912baad70c74ad9fc929b5b55b 100644 (file)
@@ -80,9 +80,9 @@ define Host/Configure/Default
        $(if $(HOST_CONFIGURE_PARALLEL),+)(cd $(HOST_BUILD_DIR)/$(3); \
                if [ -x configure ]; then \
                        $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(HOST_BUILD_DIR)/$(3)/ && \
+                       $(HOST_CONFIGURE_VARS) \
                        $(2) \
                        $(HOST_CONFIGURE_CMD) \
-                       $(HOST_CONFIGURE_VARS) \
                        $(HOST_CONFIGURE_ARGS) \
                        $(1); \
                fi \