fix NO_TRACE_MAKE
authorFelix Fietkau <nbd@openwrt.org>
Sat, 22 Jul 2006 12:16:26 +0000 (12:16 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 22 Jul 2006 12:16:26 +0000 (12:16 +0000)
SVN-Revision: 4205

openwrt/include/verbose.mk

index 7d9b3979bffcb171ff025375d4c1324a6ebca5ab..525fbf1c157178e6d4e2c4c39fa0a93222e31bba 100644 (file)
@@ -6,13 +6,16 @@
 #
 # $Id:$
 
-export NO_TRACE_MAKE:=$(MAKE) V=99
+ifeq ($(NO_TRACE_MAKE),)
+NO_TRACE_MAKE := $(MAKE) V=99
+export NO_TRACE_MAKE
+endif
 
 ifndef KBUILD_VERBOSE
-  KBUILD_VERBOSE=0
-  ifeq ("$(origin V)", "command line")
-    KBUILD_VERBOSE=$(V)
-  endif
+  KBUILD_VERBOSE:=0
+endif
+ifeq ("$(origin V)", "command line")
+  KBUILD_VERBOSE:=$(V)
 endif
 
 ifneq ($(KBUILD_VERBOSE),99)