imagebuilder: use FreeBSD compatible tar invocation
authorJo-Philipp Wich <jow@openwrt.org>
Fri, 6 Feb 2015 00:27:06 +0000 (00:27 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Fri, 6 Feb 2015 00:27:06 +0000 (00:27 +0000)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 44288

target/imagebuilder/Makefile

index 82fdab40d8e51ba24617794867e7216b5cfc6575..ecb8ac7cf4af8756370046afebd21e366c7ce7f2 100644 (file)
@@ -58,7 +58,7 @@ $(BIN_DIR)/$(IB_NAME).tar.bz2: clean
        find $(STAGING_DIR_HOST)/bin -maxdepth 1 -type f -perm -u=x \
          | $(XARGS) $(SCRIPT_DIR)/bundle-libraries.sh $(PKG_BUILD_DIR)/staging_dir/host/bin
        $(MAKE) -C $(PKG_BUILD_DIR) package_index
-       $(TAR) c -C $(BUILD_DIR) $(IB_NAME) | bzip2 -c > $@
+       $(TAR) -cf - -C $(BUILD_DIR) $(IB_NAME) | bzip2 -c > $@
 
 download:
 prepare: