rssileds: Fix build with external toolchains
authorFlorian Fainelli <f.fainelli@gmail.com>
Mon, 13 Feb 2017 02:34:53 +0000 (18:34 -0800)
committerFlorian Fainelli <f.fainelli@gmail.com>
Thu, 2 Mar 2017 01:19:52 +0000 (17:19 -0800)
Pass down TARGET_CPPFLAGS for path to header files, and append the
libraries we depend on in TARGET_LDFLAGS. Put TARGET_LDFLAGS at the end
of the command line as is required by modern GCC/binutils.

Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
package/network/utils/rssileds/Makefile

index e475bcd5bb9a9fa8380e217ea22dc14604b9d8d5..d3fb66adc9f5d3c60f358549eba7209396b09661 100644 (file)
@@ -29,9 +29,11 @@ endef
 define Build/Configure
 endef
 
+TARGET_LDFLAGS += -liwinfo -luci -lubox -lnl-tiny
+
 define Build/Compile
-       $(TARGET_CC) $(TARGET_CFLAGS) -Wall -liwinfo \
-               -o $(PKG_BUILD_DIR)/rssileds $(PKG_BUILD_DIR)/rssileds.c
+       $(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_CPPFLAGS) -Wall \
+               -o $(PKG_BUILD_DIR)/rssileds $(PKG_BUILD_DIR)/rssileds.c $(TARGET_LDFLAGS)
 endef
 
 define Package/rssileds/install